Windows 10 Client - Service not working

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
Turnspit
OpenVpn Newbie
Posts: 3
Joined: Mon Jul 20, 2020 9:07 am

Windows 10 Client - Service not working

Post by Turnspit » Sat Jul 25, 2020 7:47 am

Cheers!

I'm trying to get the OpenVPN service running on a freshly installed Windows 10 1909 machine. While connecting via GUI works without any hassle, the service doesn't wanna start.

The log created by the service isn't very helpful:

Log

Fri Jul 24 14:19:19 2020 OpenVPN 2.4.9 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Apr 16 2020
Fri Jul 24 14:19:19 2020 Windows version 6.2 (Windows 8 or greater) 64bit
Fri Jul 24 14:19:19 2020 library versions: OpenSSL 1.1.1f 31 Mar 2020, LZO 2.10


And in the event viewer I get the following error message:

openvpnserv error:
StartServiceCtrlDispatcher failed.


I hope someone can help me out here!

Thanks in advance! :-)

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7584
Joined: Fri Jun 03, 2016 1:17 pm

Re: Windows 10 Client - Service not working

Post by TinCanTech » Sat Jul 25, 2020 10:29 am

Turnspit wrote:
Sat Jul 25, 2020 7:47 am
the service doesn't wanna start
Works for me ..

Turnspit
OpenVpn Newbie
Posts: 3
Joined: Mon Jul 20, 2020 9:07 am

Re: Windows 10 Client - Service not working

Post by Turnspit » Wed Jul 29, 2020 10:26 am

Thanks for that absolutely moronic and completely useless comment.


For any sane person that might stumble upon this thread having the same problem as I do:

I needed to set the OpenVPNService to start automatically as well as create new scheduled task ( refer to: https://strongvpn.com/autoconnect-windows-10-openvpn/ ). In contrast to the aforementioned guide I set the task to start "When the computer starts" and made it "Run whether user is logged on or not".

Running the service as well as the scheduled task in conjunction let's OpenVPN correctly connect on startup before any login. Running the service or the task on it's own both isn't working. While the service alone won't do anything, the scheduled task running on it's own connects to the OpenVPN server, but seems to have problems with some parts of the config since I'm then not able to access the internet.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 7584
Joined: Fri Jun 03, 2016 1:17 pm

Re: Windows 10 Client - Service not working

Post by TinCanTech » Wed Jul 29, 2020 11:15 am

Turnspit wrote:
Wed Jul 29, 2020 10:26 am
Thanks for that absolutely moronic and completely useless comment
Reflecting the exact same high quality of your initial question ...

300000
OpenVPN Super User
Posts: 215
Joined: Tue May 01, 2012 9:30 pm

Re: Windows 10 Client - Service not working

Post by 300000 » Wed Jul 29, 2020 1:40 pm

Freeware software mean nobody need to answer anything at all if nothing make it interesting.why people come here to complain instead contribute to other.

Post Reply