OpenVPN Unstable/Unsable - ISP blocking it?

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
BY_Zaca
OpenVpn Newbie
Posts: 1
Joined: Tue Aug 06, 2019 7:32 am

OpenVPN Unstable/Unsable - ISP blocking it?

Post by BY_Zaca » Tue Aug 06, 2019 9:00 am

Hi.

I have a openvpn server running on a dedicated server and it works amazingly fine on a Computer "A" that uses the internet "A".

However, a Computer "B" that uses the internet "B" is unstable on a point that you cant even surf on the internet.

Image

192.168.1.1 = Router gateway
10.10.10.1 = openvpn gateway

I have tried connecting over TCP and UDP, tried changing the default ports to random ports, tried windows and linux, tried different computers from the "Internet B" network, tried connecting the modem directly on the computer and setting up the PPPOE (the ISP uses this protocol to provide internet) to prove that the router was not blocking openvpn, tried lowering the PPPOE and Openvpn MTU, tried different VPN server on a completely different server with a completely different route but still exactly same problem.

Direct TCP and UDP connection from this Computer B to the server where is running the openvpn server is fine, no packet loss and i can get full speed. Things gets bad when i connected on the vpn. The funny thing is that PPTP and L2TP also works fine on this server where openvpn is running.

Any one ever had something similar?
Thanks!

Post Reply