Tun0 Interface missing

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
PierAzzo57
OpenVpn Newbie
Posts: 1
Joined: Tue Jul 30, 2019 9:15 am

Tun0 Interface missing

Post by PierAzzo57 » Tue Jul 30, 2019 9:26 am

Dear Community,

I installed openvpn application on my raspberry 3.
Installation & configuration are already done but there is an issue, vpn isn't working because tun0 interface isn't available.
You will find every information bellow.

pi@raspberrypi:~ $ ifconfig -a
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 10.0.0.103 netmask 255.255.255.0 broadcast 10.0.0.255
inet6 fe80::26f6:5506:6ffd:473a prefixlen 64 scopeid 0x20<link>
ether b8:27:eb:ee:7e:89 txqueuelen 1000 (Ethernet)
RX packets 83850 bytes 10058397 (9.5 MiB)
RX errors 0 dropped 162 overruns 0 frame 0
TX packets 37073 bytes 4287673 (4.0 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 8 bytes 448 (448.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 8 bytes 448 (448.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

pi@raspberrypi:~ $ sudo service openvpn status
● openvpn.service - OpenVPN service
Loaded: loaded (/lib/systemd/system/openvpn.service; enabled; vendor preset: enabled)
Active: active (exited) since Sun 2019-07-28 10:22:22 BST; 1 day 23h ago
Process: 2475 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
Main PID: 2475 (code=exited, status=0/SUCCESS)
Tasks: 0 (limit: 4915)
CGroup: /system.slice/openvpn.service

Jul 28 10:22:22 raspberrypi systemd[1]: Starting OpenVPN service...
Jul 28 10:22:22 raspberrypi systemd[1]: Started OpenVPN service.


pi@raspberrypi:~ $ cat /etc/openvpn/openvpn.conf
dev tun
proto udp
port 1195

ca /etc/openvpn/easy-rsa/keys/ca.crt
cert /etc/openvpn/easy-rsa/keys/server.crt
key /etc/openvpn/easy-rsa/keys/server.key
dh /etc/openvpn/easy-rsa/keys/dh2048.pem

server 10.8.0.0 255.255.255.0

push "redirect-gateway def1 bypass-dhcp"
push "dhcp-option DNS 5.158.255.244"
push "dhcp-option DNS 8.8.8.8"
log-append /var/log/openvpn

persist-key
persist-tun
user nobody
group nogroup
status /var/log/openvpn-status.log
verb 4
client-to-client
comp-lzo

pi@raspberrypi:~ $ lsmod |grep tun
tun 45056 0

Can you help me please ?
Waiting for you response.
Best Regards,

Pierre AZZOPARDI

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 5863
Joined: Fri Jun 03, 2016 1:17 pm

Re: Tun0 Interface missing

Post by TinCanTech » Tue Jul 30, 2019 11:48 am

/var/log/openvpn please ..

Post Reply