OpenVPN Performance (TCP)

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
bigjohns97
OpenVpn Newbie
Posts: 5
Joined: Wed Jan 03, 2018 3:10 am

OpenVPN Performance (TCP)

Post by bigjohns97 » Mon Jan 07, 2019 8:15 pm

I have an install of Openvpn running on a Hyper-V VM with a single core from a 9700k and 1GB of ram.

Recently i have had to switch over to TCP instead of UDP and am noticing that my speed is limited around 20-30mbs.

I used the default build from PiVPN with the exception of using TCP instead of UDP and i feel like the performance should be much better.

I do have a 1Gb fiber connection with no limit on download and upload.

my client connection speed test is well over 100mbit so the network speed should be there.

BTW when doing my speed tests the cpu usage on the VM is around 0-1%.

I feel like there should be something that would drive the CPU a little and gain some performance.

Here is my server config below.

dev tun
proto tcp
port 1194
ca
cert
key
dh none
topology subnet
server 10.8.0.0 255.255.255.0
push "route 192.168.1.0 255.255.255.0"
client-to-client
keepalive 1800 3600
remote-cert-tls client
tls-version-min 1.2
tls-crypt
cipher AES-256-CBC
auth SHA256
user nobody
group nogroup
persist-key
persist-tun
crl-verify
status /var/log/openvpn-status.log 20
status-version 3
syslog
verb 3

jafree
OpenVpn Newbie
Posts: 4
Joined: Thu Dec 13, 2018 9:18 am

Re: OpenVPN Performance (TCP)

Post by jafree » Wed Jan 09, 2019 7:22 am

I can't get OpenVPN to do more than 10mbit. I'm using UDP and a "tun" adapter. The device is 100mbit and I can definitely see that throughput on it. However, once I route via OpenVPN, it won't go above 10mbit.

Post Reply