Connection to OpenVPN OK but no internet through VPN

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
ryosaeba
OpenVpn Newbie
Posts: 1
Joined: Fri Sep 08, 2017 9:37 am

Connection to OpenVPN OK but no internet through VPN

Post by ryosaeba » Tue Sep 19, 2017 10:39 am

Hi guys,

I'm new in OpenVPN. I successfully installed OpenVPN server and client. I can connect my client to the server but i don't have access to internet.
I can't solve this problem.

Server : Ubuntu 14.0.2 LTS
OpenVPN 2.3.2

server.conf :

[oconf=]port 1194
proto udp
dev tun
ca ca.crt
cert equaternaire_server.crt
key equaternaire_server.key
dh dh2048.pem
push "redirect-gateway def1"
push "dhcp-option DNS 10.8.0.1"
keepalive 10 120
cipher BF-CBC # Blowfish (default)
comp-lzo
user nobody
group nogroup
persist-key
persist-tun
status openvpn-status.log
verb 5
mute 20

#push "dhcp-option DNS 208.67.222.222"
#push "dhcp-option DNS 208.67.220.220"
push "dhcp-option DNS 10.8.0.1"
#push "dhcp-option DNS 8.8.8.8"
#push "dhcp-option DNS 8.8.4.4"
[/oconf]

IPTABLES :

Chain INPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain FORWARD (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
ACCEPT all -- anywhere anywhere


Client : Windows 8.1
OpenVPN 2.4.3

client.ovpn :

[oconf=]
client
dev tun
proto udp
remote 62.210.246.68 1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert client1.crt
key client1.key
cipher BF-CBC
comp-lzo
verb 3
mute 20
[/oconf]

After connect to VPN server :
- i can ping 10.0.8.1 from my client
- i don't lose my putty connection between my local machine and my server
- i don't lose my WinSCP connection between my local machine and my server
- i can't browse the web

Thanks for help and sorry for my bad english


klanimantsi
OpenVPN User
Posts: 13
Joined: Mon Sep 04, 2017 9:00 am

Re: Connection to OpenVPN OK but no internet through VPN

Post by klanimantsi » Wed Sep 20, 2017 10:06 am

Good link, here's https://www.1and1.com/digitalguide/server/configuration/vpn-server-set-up-via-raspberry-pi-and-openvpn/ on configuring OpenVPN, although with Raspberry Pi. Let us know how it goes!

Post Reply