Can access web admin but cannot initiate tunnel

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
tmwoods
OpenVpn Newbie
Posts: 2
Joined: Tue Nov 30, 2021 10:19 pm

Can access web admin but cannot initiate tunnel

Post by tmwoods » Tue Nov 30, 2021 10:25 pm

Our router died last night and I've just put in a replacement (same model) with an older config (was missing the OpenVPN changes) so I've been trying to do them from scratch.

It is an EdgeRouter Lite (running EdgeOS).

Our server is running on a local 192 IP, on UDP port 1194 with TCP on 443.

On the router, I added port forwarding to these, plus TCP to 943 (I saw in a setup guide to do this).
I've also set up a firewall rule to accept requests to that IP on UDP 1194.

I can now successfully go to my router's IP address and access the admin web UI, but any connection I attempt with the VPN Client times out. The logs look like this (I've replaced my router's IP with 'MY_IPADDRESS'):

Code: Select all

⏎11/30/2021, 11:52:06 AM EVENT: WAIT ⏎11/30/2021, 11:52:06 AM EVENT: TRANSPORT_ERROR Transport error on 'MY_IPADDRESS: NETWORK_EOF_ERROR⏎11/30/2021, 11:52:10 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:10 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:10 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:10 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:10 AM EVENT: WAIT ⏎11/30/2021, 11:52:14 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:14 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:14 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:14 AM EVENT: WAIT ⏎11/30/2021, 11:52:14 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:14 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:18 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:18 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:18 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:18 AM EVENT: WAIT ⏎11/30/2021, 11:52:18 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:18 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:22 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:22 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:22 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:22 AM EVENT: WAIT ⏎11/30/2021, 11:52:22 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:22 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:26 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:26 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:26 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:26 AM EVENT: WAIT ⏎11/30/2021, 11:52:26 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:26 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:30 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:30 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:30 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:30 AM EVENT: WAIT ⏎11/30/2021, 11:52:30 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:30 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:34 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:34 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:34 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:34 AM EVENT: WAIT ⏎11/30/2021, 11:52:34 AM Contacting MY_IPADDRESS:1194 via UDP
⏎11/30/2021, 11:52:34 AM Connecting to [MY_IPADDRESS]:1194 (MY_IPADDRESS) via UDPv4
⏎11/30/2021, 11:52:38 AM Server poll timeout, trying next remote entry...
⏎11/30/2021, 11:52:38 AM EVENT: RECONNECTING ⏎11/30/2021, 11:52:38 AM EVENT: RESOLVE ⏎11/30/2021, 11:52:38 AM EVENT: WAIT ⏎11/30/2021, 11:52:38 AM Contacting MY_IPADDRESS:443 via TCPv4
⏎11/30/2021, 11:52:39 AM Connecting to [MY_IPADDRESS]:443 (MY_IPADDRESS) via TCPv4
⏎11/30/2021, 11:52:39 AM TCP recv EOF
⏎11/30/2021, 11:52:39 AM Transport Error: Transport error on 'MY_IPADDRESS: NETWORK_EOF_ERROR
⏎11/30/2021, 11:52:39 AM Client terminated, restarting in 5000 ms...
⏎11/30/2021, 11:52:39 AM EVENT: TRANSPORT_ERROR Transport error on 'MY_IPADDRESS: NETWORK_EOF_ERROR⏎



Can anyone point to where I'm going wrong? Am I missing some crucial step? I don't think it has anything to do with my config on the server, as this was working as recently as last night before our router died (so I'm pretty confident there is some setup I need to do on the router itself).

Thanks!

tmwoods
OpenVpn Newbie
Posts: 2
Joined: Tue Nov 30, 2021 10:19 pm

Re: Can access web admin but cannot initiate tunnel

Post by tmwoods » Wed Dec 01, 2021 4:35 pm

I would delete this but I can't seem to figure out how, but maybe someone can learn from my idiocy.

In case anyone ever runs into this issue, the reason this didn't work for me was because of the port forwarding.
I had set all the ports to forward from our public port to 443/943 and 1194.
What I should have done is set just 443/943 from our public port, then done 1194 to 1194.

e.g.:
mypublicIP:4567 -> myOpenVPNIP:443
mypublicIP:4567 -> myOpenVPNIP:943
mypublicIP:1149 -> myOpenVPNIP:1149 --This is the one I had on the wrong public port

User avatar
TinCanTech
Forum Team
Posts: 10268
Joined: Fri Jun 03, 2016 1:17 pm

Re: Can access web admin but cannot initiate tunnel

Post by TinCanTech » Wed Dec 01, 2021 6:29 pm

If you really want it deleted then that can be done.

However, we all make mistakes.. Thanks for updating your thread 8-)

Post Reply