"Outgoing TUN queue full" after upgrading from Linux Stretch to Buster on Raspberry Pi

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
DerEchteMatze
OpenVpn Newbie
Posts: 2
Joined: Wed Nov 24, 2021 11:02 pm

"Outgoing TUN queue full" after upgrading from Linux Stretch to Buster on Raspberry Pi

Post by DerEchteMatze » Wed Nov 24, 2021 11:19 pm

Hi,
after updating my Raspberry Pi installations from stretch to buster i´m unable to establish my vpn tunnel. Before the tunnel was established without problems.
On the client it looks like ok at first

Code: Select all

Wed Nov 24 23:12:16 2021 us=71085 Initialization Sequence Completed
WrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrWrW
In this situation i can´t ping the opposite tunnel-device. And after a minute it disconnects

Code: Select all

Wed Nov 24 23:13:15 2021 us=651682 [server] Inactivity timeout (--ping-restart), restarting
Wed Nov 24 23:13:15 2021 us=653613 TCP/UDP: Closing socket
Wed Nov 24 23:13:15 2021 us=654571 SIGUSR1[soft,ping-restart] received, process restarting
On the serverside i see the following error

Code: Select all

RWed Nov 24 23:13:13 2021 us=352624 client1/192.168.101.105:42100 MULTI: Outgoing TUN queue full, dropped packet len=42
RWed Nov 24 23:13:14 2021 us=409811 client1/192.168.101.105:42100 MULTI: Outgoing TUN queue full, dropped packet len=42
RWed Nov 24 23:13:15 2021 us=446807 client1/192.168.101.105:42100 MULTI: Outgoing TUN queue full, dropped packet len=42
Nothing is changed after the upgrade. Is there any option to extend the "TUN queue"?

Thanks for your help!

Regards
Matze

User avatar
TinCanTech
Forum Team
Posts: 9979
Joined: Fri Jun 03, 2016 1:17 pm

Re: "Outgoing TUN queue full" after upgrading from Linux Stretch to Buster on Raspberry Pi

Post by TinCanTech » Wed Nov 24, 2021 11:35 pm

DerEchteMatze wrote:
Wed Nov 24, 2021 11:19 pm
after updating my Raspberry Pi installations from stretch to buster
Did you use https://pivpn.io/ to install your VPN ?

DerEchteMatze
OpenVpn Newbie
Posts: 2
Joined: Wed Nov 24, 2021 11:02 pm

Re: "Outgoing TUN queue full" after upgrading from Linux Stretch to Buster on Raspberry Pi

Post by DerEchteMatze » Fri Nov 26, 2021 3:14 pm

Hi,
no. I installed by hand.

But in the meantime i have found the problem.

My up-Script inside openvpn was

Code: Select all

brctl addif br0 tap0
That worked for linux jessie and stretch. But when you move to buster you need to change it to

Code: Select all

brctl addif br0 $1
ifconfig $1 up
With this modification the message dissapers and the tunnel is working again.

Post Reply