Raspberry Pi Client not being given IP Address

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
lankylad
OpenVpn Newbie
Posts: 4
Joined: Tue Jun 30, 2020 12:41 pm

Raspberry Pi Client not being given IP Address

Post by lankylad » Sat Oct 23, 2021 5:52 pm

I am using Openvpn and Debian on my Respberry Pi to connect to my Netgear R7000 router. The router is working correctly for my windows and ios clients, so doesnt seem to be the problem.

My config file is as follows:
[oconf=]
client
dev tap
proto udp
remote R7000 12974
resolv-retry infinite
nobind
persist-key
persist-tun
ca ca.crt
cert client.crt
key client.key
cipher AES-128-CBC
comp-lzo
verb 5
tls-version-min 1.0
log /var/log/openvpn/vpn.log
[/oconf]
The connection is being made, but I'm not getting an IP Address allocated.

When I add the following line to my config file:
ifconfig 10.0.0.100 255.255.255.0

Everything works correctly

I have a workaround, but would be interested to know why I cant get DHCP to give me an IP Address

User avatar
TinCanTech
Forum Team
Posts: 9985
Joined: Fri Jun 03, 2016 1:17 pm

Re: Raspberry Pi Client not being given IP Address

Post by TinCanTech » Sat Oct 23, 2021 6:18 pm

Does your client have a DHCP solution installed ?

lankylad
OpenVpn Newbie
Posts: 4
Joined: Tue Jun 30, 2020 12:41 pm

Re: Raspberry Pi Client not being given IP Address

Post by lankylad » Sat Oct 23, 2021 9:30 pm

The Raspberry Pi successfully obtains IP Addresses from other local DHCP servers, so I think that must be the case (unless Openvpn uses a different one?)

Post Reply