Server poll timeout

This forum is for admins who are looking to build or expand their OpenVPN setup.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
Nahuel
OpenVpn Newbie
Posts: 19
Joined: Mon Mar 01, 2021 10:39 pm

Server poll timeout

Post by Nahuel » Thu Jun 17, 2021 3:18 pm

Hello Everybody!

I have this weird problem, let me try to explain it.

Yesterday the building's power went out for too long and the server that runs OpenVPN shut down. When I restarted it and connected the OpenVPN server (community edition) everything seems OK, but when a client tries to connect get the "server poll timeout" error.

I've checked and the IP and port in the config are not changed, my router has the port forwarding configured exactly the same as the day before. I even tried with the server firewall turned off and had no luck.

I know the config of my server is okay because it was working with the help Tin gave me here: viewtopic.php?t=31945

I don't know what else to check. Hope anyone here can help me.

User avatar
Pippin
Forum Team
Posts: 997
Joined: Wed Jul 01, 2015 8:03 am

Re: Server poll timeout

Post by Pippin » Thu Jun 17, 2021 3:39 pm

What does the line

Code: Select all

remote x.x.x.x
look like in the client configuration?

Nahuel
OpenVpn Newbie
Posts: 19
Joined: Mon Mar 01, 2021 10:39 pm

Re: Server poll timeout

Post by Nahuel » Thu Jun 17, 2021 4:15 pm

It has the IP and port of the server.

something like 99.99.99.99 99999

User avatar
Pippin
Forum Team
Posts: 997
Joined: Wed Jul 01, 2015 8:03 am

Re: Server poll timeout

Post by Pippin » Thu Jun 17, 2021 4:19 pm

Did the IP change after
the building's power went out for too long
?

Nahuel
OpenVpn Newbie
Posts: 19
Joined: Mon Mar 01, 2021 10:39 pm

Re: Server poll timeout

Post by Nahuel » Thu Jun 17, 2021 4:29 pm

nop, we have Static IP, and I checked that too

User avatar
Pippin
Forum Team
Posts: 997
Joined: Wed Jul 01, 2015 8:03 am

Re: Server poll timeout

Post by Pippin » Thu Jun 17, 2021 4:36 pm

Do you see the connection attempt from the client in the server log?
Redo the portforward in the router and double check everything between client and server.

Nahuel
OpenVpn Newbie
Posts: 19
Joined: Mon Mar 01, 2021 10:39 pm

Re: Server poll timeout

Post by Nahuel » Thu Jun 17, 2021 4:45 pm

I don't see the attemp, I tried redoing the portforward and even disabling the router and server firewall all together.

None of that worked

User avatar
TinCanTech
Forum Team
Posts: 9412
Joined: Fri Jun 03, 2016 1:17 pm

Re: Server poll timeout

Post by TinCanTech » Thu Jun 17, 2021 6:05 pm

Somebody pulled too many plugs out ..

The point is, your network broke and you don't know how to fix it, this has nothing to do with openvpn.

On the up-side, the best way to practice disaster recovery, is to have a disaster to recover from.

Nahuel
OpenVpn Newbie
Posts: 19
Joined: Mon Mar 01, 2021 10:39 pm

Re: Server poll timeout

Post by Nahuel » Thu Jun 17, 2021 10:41 pm

hahaha I pulled everything out just for testing, but put everything back in.

Just for the next one that finds this thread:

I had to restart my server, which launched a Windows Update, and then everything worked like a charm... Classical Windows updates right?

Many thanks to the people who tried to help

User avatar
TinCanTech
Forum Team
Posts: 9412
Joined: Fri Jun 03, 2016 1:17 pm

Re: Server poll timeout

Post by TinCanTech » Thu Jun 17, 2021 10:45 pm

Are you actually running a Windblows Server for remote access ?

If you have nothing better to do then you could try this for fun:
https://github.com/TinCanTech/easy-tls

Post Reply