Not able to set NAT settings on macOS for Connector

Next-generation cloud-hosted OpenVPN business solution.
Post Reply
pchernoff
OpenVpn Newbie
Posts: 5
Joined: Fri Mar 05, 2021 4:11 pm

Not able to set NAT settings on macOS for Connector

Post by pchernoff » Sat Mar 06, 2021 4:39 pm

I am testing OpenVPN Cloud. I've created a Network and a Connector for that network.

The subnetwork entered for the network is 192.168.100.0/23, which matches the office main LAN. Yes, the /23 is a bit unusual but that is what our consultant recommended.

I created a single Connector, downloaded the file and installed it on an iMac that we will use for this purpose temporarily.

The Status panel shows that the connector is connected to OpenVPN Cloud. I ran the line in Terminal for routing.

Now I have to set the NAT on the iMac running the Connector. The instructions state to use Internet Sharing on the Mac. No help on what to set. I look at it and the only ports listed, on both the popup and the check boxes, are Ethernet, Wi-Fi, Thunderbolt Bridge, and Bluetooth PAN. I would think there should be OpenVPN Cloud or the name of the OpenVPN network as an option for the From popup.

Any ideas?

Overall I find the documentation very good. I am now 95% of the way there. But until this is fixed OpenVPN Cloud is worthless.

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 88
Joined: Tue Feb 16, 2021 10:41 am

Re: Not able to set NAT settings on macOS for Connector

Post by openvpn_inc » Tue Apr 06, 2021 11:15 pm

Hi There,

Please try to do these steps. For enabling NAT on macOS for connector you need to execute this script:

Code: Select all

#!/bin/bash
cat > /usr/local/etc/pf-nat.conf << EOF
nat on en0 from utun0:network to any -> (en0)
EOF
sudo pfctl -d
sudo sysctl -w net.inet.ip.forwarding=1
sudo pfctl -f /usr/local/etc/pf-nat.conf -e
(where en0 is your ethernet adapter, that have access to the internet and utun0 is virtual adapter of the OpenVPN Connect app that are using for connector, you need to make sure that adapter numbers are correct)

Our documentation is updated here "nat-on-macos" if you wish to know what those commands are for.
pchernoff wrote:
Sat Mar 06, 2021 4:39 pm
I am testing OpenVPN Cloud. I've created a Network and a Connector for that network.

The subnetwork entered for the network is 192.168.100.0/23, which matches the office main LAN. Yes, the /23 is a bit unusual but that is what our consultant recommended.

I created a single Connector, downloaded the file and installed it on an iMac that we will use for this purpose temporarily.

The Status panel shows that the connector is connected to OpenVPN Cloud. I ran the line in Terminal for routing.

Now I have to set the NAT on the iMac running the Connector. The instructions state to use Internet Sharing on the Mac. No help on what to set. I look at it and the only ports listed, on both the popup and the check boxes, are Ethernet, Wi-Fi, Thunderbolt Bridge, and Bluetooth PAN. I would think there should be OpenVPN Cloud or the name of the OpenVPN network as an option for the From popup.

Any ideas?

Overall I find the documentation very good. I am now 95% of the way there. But until this is fixed OpenVPN Cloud is worthless.
Regards,
Crowley
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.nets/support

Post Reply