Page 1 of 1

Disalbe Service inside Office

Posted: Fri Sep 24, 2021 12:40 pm
by madnem
I use OpenVPN-Service for my Notebook so I have acces to my network each time already at the boot. This works very good and there are no problems as long as I'm not in the office.
To spare trafic over my firewall I set the target to on the lokal DNS-Server. The public DNS resolves the correct external IP.

The problem is: When I'm in the office, I cant ping any device on the lokal network. I can acces the internet through the lokal router ( I think this is due to that the route to the local network is still on the TAP-tunnel, witch cant connect to the firewall, because is pointing to
When I reboot the Notebook one or at least after multiple times it sets the route for the lokal network correct and i can acces the devices. When I leave the office and connect through VPN the connection is there whitout any problems.

Is the DNS-trick a good method to solve such an isue? Is there a better way to prevent the openvpn service from connection to the firewall when entering lokal network? How could I tell the service to delete the rout to the lokal network?
I do use a non adminstrator user when I'm working. This is for security reasons. The solutions to switch to admin and restart the service is not a good option.