bug in last version

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
farhaadn
OpenVPN User
Posts: 23
Joined: Wed Dec 16, 2020 10:32 am

bug in last version

Post by farhaadn » Mon Jul 26, 2021 2:01 pm

Hi, there is a bug in the last version 3.3.1(2222)
I want an old installation setup file, there is any link to archived versions?

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 288
Joined: Tue Feb 16, 2021 10:41 am

Re: bug in last version

Post by openvpn_inc » Thu Jul 29, 2021 9:55 am

Hello farhaadn,

We don't keep links to old versions online. If necessary you can alter the URL to an older version.

Regarding the bug, did you make a report about it yet to https://openvpn.net/support? If not, I suggest you do that.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

luciano.governali
OpenVpn Newbie
Posts: 2
Joined: Fri Aug 13, 2021 9:57 am

Re: bug in last version

Post by luciano.governali » Fri Aug 13, 2021 9:59 am

I have the same problem. I'd like to reinstall the previous version. How can I alter the URL?

luciano.governali
OpenVpn Newbie
Posts: 2
Joined: Fri Aug 13, 2021 9:57 am

Re: bug in last version

Post by luciano.governali » Fri Sep 10, 2021 2:27 pm

This is my log...

⏎[Sep 9, 2021, 15:36:02] EVENT: CONNECTING ⏎[Sep 9, 2021, 15:36:02] Tunnel Options:V4,dev-type tun,link-mtu 1523,tun-mtu 1500,proto TCPv4_CLIENT,keydir 1,cipher AES-256-GCM,auth [null-digest],keysize 256,tls-auth,key-method 2,tls-client
⏎[Sep 9, 2021, 15:36:02] Creds: UsernameEmpty/PasswordEmpty
⏎[Sep 9, 2021, 15:36:02] Peer Info:
IV_VER=3.git::98bf7f7f
IV_PLAT=win
IV_NCP=2
IV_TCPNL=1
IV_PROTO=30
IV_CIPHERS=AES-256-GCM:AES-128-GCM:CHACHA20-POLY1305
IV_AUTO_SESS=1
IV_GUI_VER=OCWindows_3.3.1-2222
IV_SSO=openurl,crtext

⏎[Sep 9, 2021, 15:36:02] Transport Error: OpenSSLContext::SSL::read_cleartext: BIO_read failed, cap=2576 status=-1: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed
⏎[Sep 9, 2021, 15:36:02] EVENT: CERT_VERIFY_FAIL OpenSSLContext::SSL::read_cleartext: BIO_read failed, cap=2576 status=-1: error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed⏎[Sep 9, 2021, 15:36:02] EVENT: DISCONNECTED


Fortunately VPN Azure Client is still working with the same client certificate.

Can you help me to detect the problem?

Thanks.

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 288
Joined: Tue Feb 16, 2021 10:41 am

Re: bug in last version

Post by openvpn_inc » Mon Sep 13, 2021 10:50 pm

Hello luciano.governali,

The error message says that the verification of the server certificate failed. It is as if this client is trying to connect to the wrong server. Are you absolutely sure that the connection profile you are using is actually meant for this server, and that the address of the server it is connecting to is actually correct, and resolving to the correct IP? Because I can replicate this behavior if for example I connect to the wrong server.

An identical issue was reported here, with solution and explanation as well:
viewtopic.php?f=33&t=31403

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

Post Reply