OpenVPN bug? [Images + logs]

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
imfiringmylaser12
OpenVpn Newbie
Posts: 13
Joined: Sat Jun 19, 2021 9:25 am

OpenVPN bug? [Images + logs]

Post by imfiringmylaser12 » Wed Jun 23, 2021 5:37 am

In windows I delete route 0.0.0.0 0.0.0.0 192.168.1.1 and add persisent route x.x.x.32 255.255.255.255 192.168.1.1 to the VPN. This forces all traffic through the VPN. If the VPN fails, all traffic fails and windows wont leak my IP. I can ping the VPN and should be able to connect, but it wont.

The logs show it connects, then says "cannot detect default gateway" and "ovpnagent: request error". The only solution I found is to add back route 0.0.0.0 0.0.0.0 192.168.1.1, connect to the VPN, then remove this route. Other software such as Softeher with other VPN's dont cause such problems.

This OpenVPN is running in Oracle cloud. The machine is Windows, using OpenVPN Connect.

Is this an OpenVPN bug? Why wont it connect?

Routes + proof I can ping VPN: https://i.imgur.com/cdDYsQB.png (IP ending in .32 is the VPN)

OpenVPN Connect Error log: https://pastebin.com/KNTJjE1w(I redacted the VPN IP address and other sensitive info)

Client directive config: https://i.imgur.com/URj8IPF.png (Adding or removing this route 0.0.0.0 0.0.0.0 makes no difference)

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 220
Joined: Tue Feb 16, 2021 10:41 am

Re: OpenVPN bug? [Images + logs]

Post by openvpn_inc » Wed Jun 23, 2021 12:00 pm

Hello imfiringmylaser12,

Would be so kind as to try an up-to-date version of OpenVPN Connect v3? The logs show an entry for March 2020. Particularly release 3.2.2 released on 30th of October last year has this as relevant release notes item:

> Fixed an issue where an OpenVPN server could not be reached if it was not reachable through the default gateway

So I figure it would be good to get the latest version here https://openvpn.net/downloads/openvpn-c ... indows.msi and try again.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.net/support

imfiringmylaser12
OpenVpn Newbie
Posts: 13
Joined: Sat Jun 19, 2021 9:25 am

Re: OpenVPN bug? [Images + logs]

Post by imfiringmylaser12 » Wed Jun 23, 2021 10:20 pm

This solved the problem! Yipeeeee!!!

1. The only hiccup I notice, is if I disconnect from the VPN, and attempt to reconnect or ping the server it is unable to. The VPN route in "Active routes" drops, but remains in the persistent routes. This forces me to restart windows which fixes the problem. I dont know whats causing this, but its managable, just an inconvience.

2. Now my last major issue is fixing the DNS errors when testing on www.doileak.com. OpenVPN is using is using DNS 8.8.8.8 and 1.1.1.1 and I dont see my ISPS DNS but I am getting the follow errors which I do not experience on other VPN's and would like to fix, any idea how to fix? The errors:

Connection type: "You are connected via generic tunnel or VPN and have made 8 hops. Your connection type is rather uncommon for the average internet surfer, and could suggest proxy/VPN use"

and

DNS Request Source: "We recieved DNS requests from you via a DNS server from another AS (routable network) than your HTTP request. This could mean that your DNS requests are leaking"

OpenVPN DNS settings: https://i.imgur.com/iIkPNHV.png

DNS leak results: https://i.imgur.com/HYI3e6c.png

imfiringmylaser12
OpenVpn Newbie
Posts: 13
Joined: Sat Jun 19, 2021 9:25 am

Re: OpenVPN bug? [Images + logs]

Post by imfiringmylaser12 » Thu Jun 24, 2021 12:15 am

In other words, what is the closest DNS server I can use from my Oracle Cloud OpenVPN server?

Post Reply