Page 1 of 1

RDP not working through tunnel

Posted: Sun Oct 17, 2021 11:24 am
by og6hy7
I have an OpenVPN AS server setup to connect me to my home. When I run the tunnel from Windows into my network from work, it works perfectly fine. I can access my web pages, ssh and rdp just fine.

However, when I try from IOS, RDP will not work. SSH and web pages work fine, it just seems to be RDP.

To make this issue more complicated:

If I am connected to cellular data, the issue occurs.
If I am connected to a wifi network (Exact same setup, aside from connecting network), it works just fine.

I have tried on my partners phone and the same issue occurs. If I am connected to her personal hotspot, it works just fine however.

I have uninstalled OpenVPN Connect and reinstalled it multiple times.

I am at a loss, any clue on what could be happening?

Re: RDP not working through tunnel

Posted: Mon Oct 18, 2021 6:24 am
by og6hy7
Ok, I changed mobile networks as a test (Was with Telstra, now with Optus on prepaid) and it worked fine. Sigh, stupid Telstra.

I thought by using a VPN you are hiding your traffic from your provider. Have I misconfigured something?


If I enable "Should client Internet traffic be routed through the VPN?", it works. I don't want internet traffic routed though

Re: RDP not working through tunnel

Posted: Sun Nov 28, 2021 10:45 pm
by connex
Am surprised this hasn’t been more publicly announced. It turns out that the OpenVPN client on the iPhone doesn’t send all its traffic through it. This allows the ISPs to block some of it. The solution I found was to connect to a 3rd party VPN, either before establishing the OpenVPN connection but surprisingly even afterwards works fine too. Then the ISP can’t block your traffic and you can connect without hindrance. You could also hotspot to another device first which also works.

Re: RDP not working through tunnel

Posted: Thu Jan 13, 2022 6:43 am
by deepunder
This is interesting. I’m with Telstra and can’t SSH back to my pi through OpenVPN. I can browse internal hosted pages. Why doesn’t the OpenVPN client traverse all local traffic into the vpn tunnel?

I should add that if I’m on wifi everything works. But on cellular ssh doesn’t work. But I do notice if the connection uses UDPv4 I am able to connect using ssh.