Page 1 of 1

iPhone iOS (13.3.1) Settings app OpenVPN Profile not working (works in OpenVPN client)

Posted: Tue Feb 11, 2020 11:36 pm
by Earlyflash
Hi all,

Strange error here.

I've got a OpenVPN profile I've imported into the OpenVPN iOS app on my iphone (just downloaded from the app store), and it works absolutely fine, press connect, ocnnects, no issues.

iOS Seems to have imported the VPN setup correctly to the iphone.

When I go to the iOS settings app and hit 'connect' on the 'VPN' it switches to green instantly, the 'Connecting...' flashes up, but it never actually connects. About 30s later, the selector moves back to 'dark', but no errors appear, nothing.

The server side, doesn't even seem to receive a connection request (as far as I can see).

I guess a bug in the way the connection is registered in iOS? But for now I have to do everything via the OpenVPN applciation itself ... sigh.

I also found someone else in ServerFault with the same issue:
https://stackoverflow.com/questions/598 ... it-used-to

Re: iPhone iOS (13.3.1) Settings app OpenVPN Profile not working (works in OpenVPN client)

Posted: Tue Feb 11, 2020 11:48 pm
by mdibella
This is by design. SSL-based VPN connections on iOS must be initiated within the helper app unless the profile is configured for auto-connect.

Re: iPhone iOS (13.3.1) Settings app OpenVPN Profile not working (works in OpenVPN client)

Posted: Thu Feb 13, 2020 10:51 am
by Earlyflash
Oh that's interesting! Strange UI for it though, but hey-ho.

Is that by design of Apple or OpenVPN?

Re: iPhone iOS (13.3.1) Settings app OpenVPN Profile not working (works in OpenVPN client)

Posted: Thu Feb 13, 2020 2:37 pm
by Pippin
mdibella's post seems to indicate that it's an Apple requirement.