Doesn't request "Data" permission

Post Reply
bovi
OpenVpn Newbie
Posts: 2
Joined: Mon Jul 01, 2019 2:50 pm

Doesn't request "Data" permission

Post by bovi » Mon Jul 01, 2019 2:56 pm

I'm using an iPad Pro with Cellular option. I'm having a OVPN file which runs fine on my MacBook Air and my iPhone 5SE. When I install OpenVPN Connect on the iPad I can import the OVPN file but when connecting it immediatly shows the error message: "Network is unavailable. Please try to connect later with active network". I tried it with deactivated cellular and/or deactivated WLAN. Both give me the same error messages. Based on my network logging there is no connection attempt at all leaving the iPad. When I look in the setting menu I also can't find the "OpenVPN" App Menu Entry which should allow me to activate and deactivate the iOS permissions (e.g. data access). My current working theorie would be, that there is a bug in the OpenVPN Connect which did not request this actual permission. As a matter of fact I can see the "OpenVPN" App Menu Entry on my iPhone and when I deactivate the Data access I receive the identical error message. Is it possible to force the app to register itself in iOS to require data access?

bovi
OpenVpn Newbie
Posts: 2
Joined: Mon Jul 01, 2019 2:50 pm

Re: Doesn't request "Data" permission

Post by bovi » Tue Jul 02, 2019 1:33 pm

It seems nobody else had this issue. Nevertheless I found the solution:

As expected the issue was indeed the fact that OpenVPN APP on iOS doesn't request internet access permission (not sure if this is some iOS magic). Yet to force this request I went to the start page of the app and clicked on "Private Tunnel", there you will find a "Sign Up" link which opens an in-app browser. Just click on this link and the app will try to reach the internet and with that request data permission from iOS. After these data permissions are registered in iOS the app works again. It seems some update in iOS or in the OpenVPN app messed this up.

nev4eh8959
OpenVpn Newbie
Posts: 2
Joined: Sun Jul 21, 2019 2:28 pm

Re: Doesn't request "Data" permission

Post by nev4eh8959 » Mon Jul 22, 2019 6:45 am

This worked for me. Thank you!

dongyl
OpenVpn Newbie
Posts: 1
Joined: Wed Aug 14, 2019 12:16 pm

Re: Doesn't request "Data" permission

Post by dongyl » Wed Aug 14, 2019 12:27 pm

Thank you very much. Exactly same issue, same doubt, same workaround which works finally since 11 months ago I bought the new iPhone and installed 3.0.2 version OpenVPN Connect !

Post Reply