Page 1 of 1

[Resolved] NETWORK_EOF_ERROR (transport error)

Posted: Sat Aug 26, 2017 11:25 am
by hey_aj
Have been using OpenVPN on 3 different iOS devices for weeks without issues. Yesterday, all 3 encountered the same issue- my iPad and iPhone here on business travel in Australia, my wife's iPhone back home in the US. Doesn't matter if on cell data or wifi. Key problem seems to be a transport error per the log below. Client status toggles between "waiting for server" and "transport pause" before timing out. Had wife reboot our asus router but did not resolve. Grateful for any assistance.

2017-08-26 20:59:26 EVENT: RESOLVE
2017-08-26 20:59:26 Contacting 24.9.69.17:443 via TCP
2017-08-26 20:59:26 EVENT: WAIT
2017-08-26 20:59:26 SetTunnelSocket returned 1
2017-08-26 20:59:27 Connecting to [xxxx.asuscomm.com]:443 (24.9.69.17) via TCPv4
2017-08-26 20:59:27 TCP recv EOF
2017-08-26 20:59:27 Transport Error: Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR
2017-08-26 20:59:27 EVENT: TRANSPORT_ERROR Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR [ERR]
2017-08-26 20:59:27 Client terminated, restarting in 5000 ms...
2017-08-26 20:59:27 NET Internet:ReachableViaWiFi/-R t------
2017-08-26 20:59:30 RECONNECT TEST: Internet:ReachableViaWiFi/-R t------
2017-08-26 20:59:30 Client terminated, reconnecting in 1...
2017-08-26 20:59:31 EVENT: RECONNECTING
2017-08-26 20:59:31 EVENT: RESOLVE
2017-08-26 20:59:31 Contacting 24.9.69.17:443 via TCP
2017-08-26 20:59:31 EVENT: WAIT
2017-08-26 20:59:31 SetTunnelSocket returned 1
2017-08-26 20:59:31 Connecting to [xxxx.asuscomm.com]:443 (24.9.69.17) via TCPv4
2017-08-26 20:59:32 TCP recv EOF
2017-08-26 20:59:32 Transport Error: Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR
2017-08-26 20:59:32 EVENT: TRANSPORT_ERROR Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR [ERR]
2017-08-26 20:59:32 Client terminated, restarting in 5000 ms...
2017-08-26 20:59:35 RECONNECT TEST: Internet:ReachableViaWiFi/-R t------
2017-08-26 20:59:35 Client terminated, reconnecting in 1...
2017-08-26 20:59:36 EVENT: RECONNECTING
2017-08-26 20:59:36 EVENT: RESOLVE
2017-08-26 20:59:36 Contacting 24.9.69.17:443 via TCP
2017-08-26 20:59:36 EVENT: WAIT
2017-08-26 20:59:36 SetTunnelSocket returned 1
2017-08-26 20:59:36 Connecting to [xxxx.asuscomm.com]:443 (24.9.69.17) via TCPv4
2017-08-26 20:59:36 TCP recv EOF
2017-08-26 20:59:36 Transport Error: Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR
2017-08-26 20:59:36 EVENT: TRANSPORT_ERROR Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR [ERR]
2017-08-26 20:59:36 Client terminated, restarting in 5000 ms...
2017-08-26 20:59:39 RECONNECT TEST: Internet:ReachableViaWiFi/-R t------
2017-08-26 20:59:39 Client terminated, reconnecting in 1...
2017-08-26 20:59:40 EVENT: RECONNECTING
2017-08-26 20:59:40 EVENT: RESOLVE
2017-08-26 20:59:40 Contacting 24.9.69.17:443 via TCP
2017-08-26 20:59:40 EVENT: WAIT
2017-08-26 20:59:40 SetTunnelSocket returned 1
2017-08-26 20:59:40 Connecting to [xxxx.asuscomm.com]:443 (24.9.69.17) via TCPv4
2017-08-26 20:59:41 TCP recv EOF
2017-08-26 20:59:41 Transport Error: Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR
2017-08-26 20:59:41 EVENT: TRANSPORT_ERROR Transport error on 'xxxx.asuscomm.com: NETWORK_EOF_ERROR [ERR]
2017-08-26 20:59:41 Client terminated, restarting in 5000 ms...
2017-08-26 20:59:41 EVENT: DISCONNECTED
2017-08-26 20:59:41 Raw stats on disconnect:
BYTES_OUT : 64
PACKETS_OUT : 4
NETWORK_EOF_ERROR : 4
TRANSPORT_ERROR : 4
N_RECONNECT : 3
2017-08-26 20:59:41 Performance stats on disconnect:
CPU usage (microseconds): 21531
Network bytes per CPU second: 2972
Tunnel bytes per CPU second: 0

Re: NETWORK_EOF_ERROR (transport error)

Posted: Sat Aug 26, 2017 1:45 pm
by TinCanTech
Check your server log.

Re: NETWORK_EOF_ERROR (transport error)

Posted: Mon Aug 28, 2017 8:31 am
by hey_aj
Sure, two follow-up questions:
1) I assume you are referring to the log on my router, in which case I will need to check when I return home as I am currently remote
2) Any suggestion as to what I am looking for or what the issue is? Or, just generic guidance to check the log?

Thanks

Re: NETWORK_EOF_ERROR (transport error)

Posted: Mon Aug 28, 2017 12:17 pm
by TinCanTech
You need to verify that a connection attempt was made and what went wrong.

Please see:
HOWTO: Request Help ! {2}

Re: NETWORK_EOF_ERROR (transport error)

Posted: Tue Sep 05, 2017 10:06 am
by klanimantsi
Did you verify the connection attempt was made?

Re: NETWORK_EOF_ERROR (transport error) SOLVED

Posted: Tue Sep 05, 2017 11:55 pm
by hey_aj
Finally home from travels and could log into my router (ASUS RT-ACRH13). On OpenVPN Server config page there was this message: "OpenVPN server daemon failed to start". Tried various things to restart it, including reboot. No obvious way to do this. Then noticed alert for a firmware upgrade. Did the upgrade. All good now.

Re: NETWORK_EOF_ERROR (transport error)

Posted: Wed Sep 06, 2017 12:27 am
by TinCanTech
Great .. Thanks for letting us know 8-)