Can't browse network through VPN

Post Reply
lazloman
OpenVpn Newbie
Posts: 2
Joined: Tue May 30, 2017 3:20 am

Can't browse network through VPN

Post by lazloman » Tue May 30, 2017 7:14 pm

I have OpenVPN setup under Ubuntu 16.04 and I'm connecting to it from iOS (iPhone). Connecting to the VPN works just fine, but I can't connect to any other computers on the local LAN. I'm using all the default settings for the server (tun, iOS can't connect to a tap), along with the default settings for the client as well. I can browse the internet, but I need to access a particular client on the LAN, but the connection times out. I have a utility on my iPhone that allows me to ping, traceroute, etc, but when I do a trace, the connections dies at the VPN router, 10.8.0.1, and it takes a while to get there (900ms+). All of this is setup behind an Apple Time Capsule which acts as my gateway. My local LAN is at 192.168.2.0. Does anyone have any ideas as to what I can do to get my iPhone talking to computers on the LAN? Thanks

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2992
Joined: Fri Jun 03, 2016 1:17 pm

Re: Can't browse network through VPN

Post by TinCanTech » Tue May 30, 2017 8:43 pm


lazloman
OpenVpn Newbie
Posts: 2
Joined: Tue May 30, 2017 3:20 am

Re: Can't browse network through VPN

Post by lazloman » Wed May 31, 2017 2:53 am

I think real problem is the Apple Time Capsule. You can't setup static routes on the device. I ended up installing piVPN on the Raspberry I wanted to reach. The setup took all of 15 minutes from start to finish. It took me an hour on the Linux box I wanted to use. Problem solved. Thanks for the reply.

Post Reply