Cant connect on iOS APP but it works with my Macbook

Post Reply
antrisch
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 15, 2017 8:17 am

Cant connect on iOS APP but it works with my Macbook

Post by antrisch » Wed Mar 15, 2017 9:19 am

Hi I have now read the HOW-To, the Wiki, various support sites etc and I'm stuck... :!: so if some one can help me it would be highly appreciated. :D

As already mention in the subject i mention it works fine on the mac :D but not the iphone or ipad :x

Background info:
I have a Nas server / QNAP which i have used the preinstalled openvpn server on, and created a openvpn.ovpn file and a ca.crt file
these files i downloaded to the mac and installed in Tunnelblick on my macbook, opened the UD port 1194 router and forwarded all udp 1194 traffic to the Qnap Nat IP, did a first test!!! e.g. tried to connect and it works fine from start :D

Problem/issue:
I get connection timeout on my Iphone and Ipad, which are running iOS 10,
i have installed the same files openvpn.ovpn file and a ca.crt via Itunes and the app accept thees but when i try to connect it won't work... it says connection time out, i can't understand why?

please see App logg below from ipad... any input or help is appreciated!!!


/a

2017-03-15 09:07:14 ----- OpenVPN Start -----
OpenVPN core 3.1.2 ios arm64 64-bit built on Dec 5 2016 12:50:25
2017-03-15 09:07:14 Frame=512/2048/512 mssfix-ctrl=1250
2017-03-15 09:07:14 UNUSED OPTIONS
2 [script-security] [3]
5 [resolv-retry] [infinite]
6 [nobind]
11 [tls-cipher] [TLS-SRP-SHA-RSA-WITH-3DES-EDE-CBC-SHA:TLS-DHE-RSA-WITH-AES-128-C...]

2017-03-15 09:07:14 EVENT: RESOLVE
2017-03-15 09:07:14 Contacting "IP-adress":1194 via UDP
2017-03-15 09:07:14 EVENT: WAIT
2017-03-15 09:07:14 SetTunnelSocket returned 1
2017-03-15 09:07:14 Connecting to ["IP-adress"]:1194 ("IP-adress") via UDPv4
2017-03-15 09:07:14 EVENT: CONNECTING
2017-03-15 09:07:14 Tunnel Options:V4,dev-type tun,link-mtu 1558,tun-mtu 1500,proto UDPv4,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2017-03-15 09:07:14 Creds: Username/Password
2017-03-15 09:07:14 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.1.1-212
IV_VER=3.1.2
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_LZO=1

2017-03-15 09:07:15 NET Internet:ReachableViaWiFi/-R t------
2017-03-15 09:07:54 Session invalidated: KEEPALIVE_TIMEOUT
2017-03-15 09:07:54 Client terminated, restarting in 2000 ms...
2017-03-15 09:07:56 EVENT: RECONNECTING
2017-03-15 09:07:56 EVENT: RESOLVE
2017-03-15 09:07:56 Contacting "IP-adress":1194 via UDP
2017-03-15 09:07:56 EVENT: WAIT
2017-03-15 09:07:56 SetTunnelSocket returned 1
2017-03-15 09:07:56 Connecting to ["IP-adress"]:1194 ("IP-adress") via UDPv4
2017-03-15 09:07:56 EVENT: CONNECTING
2017-03-15 09:07:56 Tunnel Options:V4,dev-type tun,link-mtu 1558,tun-mtu 1500,proto UDPv4,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2017-03-15 09:07:56 Creds: Username/Password
2017-03-15 09:07:56 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.1.1-212
IV_VER=3.1.2
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_LZO=1

2017-03-15 09:08:14 EVENT: CONNECTION_TIMEOUT [ERR]
2017-03-15 09:08:14 EVENT: DISCONNECTED
2017-03-15 09:08:14 Raw stats on disconnect:
BYTES_IN : 96
BYTES_OUT : 10172
PACKETS_IN : 4
PACKETS_OUT : 62
KEEPALIVE_TIMEOUT : 1
CONNECTION_TIMEOUT : 1
N_RECONNECT : 1
2017-03-15 09:08:14 Performance stats on disconnect:
CPU usage (microseconds): 25834
Network bytes per CPU second: 397460
Tunnel bytes per CPU second: 0
2017-03-15 09:08:14 EVENT: DISCONNECT_PENDING
2017-03-15 09:08:14 ----- OpenVPN Stop -----
2017-03-15 09:09:20 ----- OpenVPN Start -----
OpenVPN core 3.1.2 ios arm64 64-bit built on Dec 5 2016 12:50:25
2017-03-15 09:09:20 Frame=512/2048/512 mssfix-ctrl=1250
2017-03-15 09:09:20 UNUSED OPTIONS
2 [script-security] [3]
5 [resolv-retry] [infinite]
6 [nobind]
11 [tls-cipher] [TLS-SRP-SHA-RSA-WITH-3DES-EDE-CBC-SHA:TLS-DHE-RSA-WITH-AES-128-C...]

2017-03-15 09:09:20 EVENT: RESOLVE
2017-03-15 09:09:20 Contacting "IP-adress":1194 via UDP
2017-03-15 09:09:20 EVENT: WAIT
2017-03-15 09:09:20 SetTunnelSocket returned 1
2017-03-15 09:09:20 Connecting to ["IP-adress"]:1194 ("IP-adress") via UDPv4
2017-03-15 09:09:20 EVENT: CONNECTING
2017-03-15 09:09:20 Tunnel Options:V4,dev-type tun,link-mtu 1558,tun-mtu 1500,proto UDPv4,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2017-03-15 09:09:20 Creds: Username/Password
2017-03-15 09:09:20 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.1.1-212
IV_VER=3.1.2
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_LZO=1

2017-03-15 09:09:21 NET Internet:ReachableViaWiFi/-R t------
2017-03-15 09:10:00 Session invalidated: KEEPALIVE_TIMEOUT
2017-03-15 09:10:00 Client terminated, restarting in 2000 ms...
2017-03-15 09:10:02 EVENT: RECONNECTING
2017-03-15 09:10:02 EVENT: RESOLVE
2017-03-15 09:10:02 Contacting "IP-adress":1194 via UDP
2017-03-15 09:10:02 EVENT: WAIT
2017-03-15 09:10:02 SetTunnelSocket returned 1
2017-03-15 09:10:02 Connecting to ["IP-adress"]:1194 ("IP-adress") via UDPv4
2017-03-15 09:10:02 EVENT: CONNECTING
2017-03-15 09:10:02 Tunnel Options:V4,dev-type tun,link-mtu 1558,tun-mtu 1500,proto UDPv4,comp-lzo,cipher AES-256-CBC,auth SHA1,keysize 256,key-method 2,tls-client
2017-03-15 09:10:02 Creds: Username/Password
2017-03-15 09:10:02 Peer Info:
IV_GUI_VER=net.openvpn.connect.ios 1.1.1-212
IV_VER=3.1.2
IV_PLAT=ios
IV_NCP=2
IV_TCPNL=1
IV_PROTO=2
IV_LZO=1

2017-03-15 09:10:20 EVENT: CONNECTION_TIMEOUT [ERR]
2017-03-15 09:10:20 EVENT: DISCONNECTED
2017-03-15 09:10:20 Raw stats on disconnect:
BYTES_IN : 96
BYTES_OUT : 10172
PACKETS_IN : 4
PACKETS_OUT : 62
KEEPALIVE_TIMEOUT : 1
CONNECTION_TIMEOUT : 1
N_RECONNECT : 1
2017-03-15 09:10:20 Performance stats on disconnect:
CPU usage (microseconds): 33805
Network bytes per CPU second: 303742
Tunnel bytes per CPU second: 0
2017-03-15 09:10:20 EVENT: DISCONNECT_PENDING
2017-03-15 09:10:20 ----- OpenVPN Stop -----

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2968
Joined: Fri Jun 03, 2016 1:17 pm

Re: Cant connect on iOS APP but it works with my Macbook

Post by TinCanTech » Wed Mar 15, 2017 11:58 am

What does your server log have regarding your connection attempt ?

(Something about shared ciphers .. )

antrisch
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 15, 2017 8:17 am

Re: Cant connect on iOS APP but it works with my Macbook

Post by antrisch » Wed Mar 15, 2017 8:53 pm

Hi i have now tried to find the openvpn server log in my Qnap.

No luck started to look in /var/log/....

and found these files and the did not say much...
/var/log/
openvpn-status.log
openvpn_disconnect.log
openvpn_online_user.log

i alos went in to the server.conf and changed this row from

#log /tmp/openvpn.log

to

log /tmp/openvpn.log

but no logg files appears, and when I'm restarting the openvpn server from the Qnap menu it rewrites the server.conf

can i run it in a debug mode if so how?

I looked on above files via ssh to the Qnap-server (used the terminal on my mac)

/a

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2968
Joined: Fri Jun 03, 2016 1:17 pm

Re: Cant connect on iOS APP but it works with my Macbook

Post by TinCanTech » Thu Mar 16, 2017 1:04 am

Can you ssh into your NAS ?

antrisch
OpenVpn Newbie
Posts: 3
Joined: Wed Mar 15, 2017 8:17 am

Re: Cant connect on iOS APP but it works with my Macbook

Post by antrisch » Thu Mar 16, 2017 5:04 pm

Yes i use SSH to look at the files

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 2968
Joined: Fri Jun 03, 2016 1:17 pm

Re: Cant connect on iOS APP but it works with my Macbook

Post by TinCanTech » Thu Mar 16, 2017 6:08 pm

Can you run your openvpn server from the ssh shell ?

rlevy
OpenVpn Newbie
Posts: 2
Joined: Mon Nov 14, 2016 11:52 pm

Re: Cant connect on iOS APP but it works with my Macbook

Post by rlevy » Sat Apr 22, 2017 4:23 pm

I had the same issue (see: viewtopic.php?t=23096) and was able to resolve it.

I was able to fix this by changing the transport protocol on the VPN server from UDP to TCP, and then modifying the openvpn config file to "proto tcp" instead of "proto udp".

taemo
OpenVpn Newbie
Posts: 1
Joined: Fri Jul 21, 2017 5:32 pm

Re: Cant connect on iOS APP but it works with my Macbook

Post by taemo » Fri Jul 21, 2017 5:33 pm

hi, were you able to resolve this issue?

having the same problem with my QNAP as well and Iphone.
Works no problem on remote desktop/laptop.

I've tried changing UDP to TCP and did not work for me.

Post Reply