Cannot connect from Settings screen

Post Reply
tagyoureit
OpenVpn Newbie
Posts: 3
Joined: Thu Jan 12, 2017 10:19 pm

Cannot connect from Settings screen

Post by tagyoureit » Thu Jan 12, 2017 10:48 pm

I'm on iOS 10.2 with OpenVPN 1.0.7.

I built my .ovpn from my Asus router and can connect with no problem from the OpenVPN app.

However, when I try to connect from the settings screen (also, anytime the app is closed but it tries to seamlessly reconnect), it fails. When I look at the logs, it appears that the username password is sent by OpenVPN app but not by Settings app. I do have the Save [username/password] enabled in the OpenVPN app.

OpenVPN

Code: Select all

2017-01-12 14:22:11 EVENT: CONNECTING
2017-01-12 14:22:11 Tunnel Options:V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client
2017-01-12 14:22:11 Creds: Username/Password
Settings

Code: Select all

2017-01-12 14:22:50 EVENT: CONNECTING
2017-01-12 14:22:50 Tunnel Options:V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client
2017-01-12 14:22:50 Creds: UsernameEmpty/PasswordEmpty
I tried searching the forums, and changing the settings, but still no luck. Am I missing something?

DaveTheNerd
OpenVpn Newbie
Posts: 1
Joined: Mon Apr 03, 2017 8:04 pm

Re: Cannot connect from Settings screen

Post by DaveTheNerd » Mon Apr 03, 2017 8:06 pm

This thread should probably be merged with another thread on the same subject where the OP here found what is likely the answer:
I saw this on the OpenVPN FAQ https://docs.openvpn.net/docs/openvpn-c ... s-faq.html, and wondering if this has anything to do with the issue at hand? I am using credentials.
Q: Can OpenVPN profiles be connected from the Settings App?

A: Yes, starting with iOS 8. Note that only autologin profiles (i.e. profiles that don't require credential entry) can be launched using this mechanism.

Post Reply