PROFILE_PARSE_ERROR

Post Reply
PRB
OpenVpn Newbie
Posts: 5
Joined: Fri Dec 21, 2012 10:02 am

PROFILE_PARSE_ERROR

Post by PRB » Fri Dec 21, 2012 10:10 am

I'm attempting to set up the app and am failing at the first step! Whem importing a working ovpn config file I receive the error: error parsing protocol:tcp-client - any pointers as to what might be wrong? ovpn file looks something like this:

float
dev tun
dev-node ovpn
proto tcp-client
remote x.x.x.x 1194
resolv-retry infinite
nobind
persist-key
persist-tun
tls-client
ca ca.crt
cert xxxx.crt
key xxxx.key
ns-cert-type server
comp-lzo
verb 3
pull
cipher AES-256-CBC

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: PROFILE_PARSE_ERROR

Post by maikcat » Fri Dec 21, 2012 10:14 am

make sure that there arent any tabs somewhere...

Michael
Amiga 500 , Zx +2 owner
Long live Dino Dini (Kick off 2 Creator)

Inflammable means flammable? (Dr Nick Riviera,Simsons Season13)

"objects in mirror are losing"

PRB
OpenVpn Newbie
Posts: 5
Joined: Fri Dec 21, 2012 10:02 am

Re: PROFILE_PARSE_ERROR

Post by PRB » Mon Dec 31, 2012 2:39 pm

maikcat wrote:make sure that there arent any tabs somewhere...

Michael
I've checked and there are definitely no tabs in the file.

P.S. I've also tried to post this reply twice without sucesss - so apols if it suddenly turns up more than once!

Phil

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: PROFILE_PARSE_ERROR

Post by maikcat » Mon Dec 31, 2012 4:43 pm

if you run openvpn with each directive manually

f.e

openvpn --float --dev tun --dev-node ovpn --proto tcp-client --remote x.x.x.x 1194
etc

is it running ok?

what version are you using?

Michael.
Amiga 500 , Zx +2 owner
Long live Dino Dini (Kick off 2 Creator)

Inflammable means flammable? (Dr Nick Riviera,Simsons Season13)

"objects in mirror are losing"

PRB
OpenVpn Newbie
Posts: 5
Joined: Fri Dec 21, 2012 10:02 am

Re: PROFILE_PARSE_ERROR

Post by PRB » Thu Jan 17, 2013 2:40 pm

I managed to get an alternative client to work (OpenVPN for Android by Arne Schwabe) with exactly the same config files. I will investigate what the issue is with the OpenVPN Connect app when I have more time but for the moment the urgency has gone away now that I have an alternative.

Thanks,

Phil

jamesyonan
OpenVPN Inc.
Posts: 169
Joined: Thu Jan 24, 2013 12:13 am

Re: PROFILE_PARSE_ERROR

Post by jamesyonan » Thu Jan 24, 2013 2:01 am

The iOS 1.0.0 client wants "tcp" instead of "tcp-client". In the upcoming 1.0.1 client we will fix this so "tcp-client" is also recognized.

James

User avatar
maikcat
Forum Team
Posts: 4202
Joined: Wed Jan 12, 2011 9:23 am
Location: Athens,Greece
Contact:

Re: PROFILE_PARSE_ERROR

Post by maikcat » Thu Jan 24, 2013 6:59 am

wow,james yonan himself answered the post?!?!?!? :mrgreen:

nice to know that he is reading the posts :)

can somebody at least give him moderator privs so he "stand out from the crowd"?

regards,

Michael.
Amiga 500 , Zx +2 owner
Long live Dino Dini (Kick off 2 Creator)

Inflammable means flammable? (Dr Nick Riviera,Simsons Season13)

"objects in mirror are losing"

PRB
OpenVpn Newbie
Posts: 5
Joined: Fri Dec 21, 2012 10:02 am

Re: PROFILE_PARSE_ERROR

Post by PRB » Fri Jan 25, 2013 9:17 am

The latest update 1.1.8 has fixed the parsing problem so I can now connect using this client.

Phil

PRB
OpenVpn Newbie
Posts: 5
Joined: Fri Dec 21, 2012 10:02 am

Re: PROFILE_PARSE_ERROR

Post by PRB » Fri Jan 25, 2013 9:20 am

I've just noticed that for some reason this thread has been moved to the IOS forum. This query was related to the Android client so please could the moderators move it back!

Phil

Post Reply