RDP not working through tunnel

Official client software for OpenVPN Access Server and OpenVPN Cloud.
Post Reply
og6hy7
OpenVpn Newbie
Posts: 2
Joined: Sun Oct 17, 2021 11:16 am

RDP not working through tunnel

Post by og6hy7 » Sun Oct 17, 2021 11:24 am

I have an OpenVPN AS server setup to connect me to my home. When I run the tunnel from Windows into my network from work, it works perfectly fine. I can access my web pages, ssh and rdp just fine.

However, when I try from IOS, RDP will not work. SSH and web pages work fine, it just seems to be RDP.

To make this issue more complicated:

If I am connected to cellular data, the issue occurs.
If I am connected to a wifi network (Exact same setup, aside from connecting network), it works just fine.

I have tried on my partners phone and the same issue occurs. If I am connected to her personal hotspot, it works just fine however.

I have uninstalled OpenVPN Connect and reinstalled it multiple times.

I am at a loss, any clue on what could be happening?

og6hy7
OpenVpn Newbie
Posts: 2
Joined: Sun Oct 17, 2021 11:16 am

Re: RDP not working through tunnel

Post by og6hy7 » Mon Oct 18, 2021 6:24 am

Ok, I changed mobile networks as a test (Was with Telstra, now with Optus on prepaid) and it worked fine. Sigh, stupid Telstra.

I thought by using a VPN you are hiding your traffic from your provider. Have I misconfigured something?

Edit:

If I enable "Should client Internet traffic be routed through the VPN?", it works. I don't want internet traffic routed though

connex
OpenVpn Newbie
Posts: 3
Joined: Mon Sep 27, 2021 12:05 am

Re: RDP not working through tunnel

Post by connex » Sun Nov 28, 2021 10:45 pm

Am surprised this hasn’t been more publicly announced. It turns out that the OpenVPN client on the iPhone doesn’t send all its traffic through it. This allows the ISPs to block some of it. The solution I found was to connect to a 3rd party VPN, either before establishing the OpenVPN connection but surprisingly even afterwards works fine too. Then the ISP can’t block your traffic and you can connect without hindrance. You could also hotspot to another device first which also works.

Post Reply