How to fix Android not using server provided DNS

Post Reply
erhan
OpenVpn Newbie
Posts: 1
Joined: Sun Dec 20, 2020 3:29 pm

How to fix Android not using server provided DNS

Post by erhan » Sun Dec 20, 2020 3:32 pm

I had the problem on Lineageos 17.1 that Android was not using the server provided DNS. The solution is the following:

Go to Settings > Network & Internet > Private DNS and set to Off

This way the server provided DNS is used and I can resolve everything correctly in the browser. If you still have problems, check your logs if the DNS directive was sent at all and use termux to test with dig hostname @ip_of_dns. Do not forget that Termux does use resolv.conf instead of the Android one. So the @ is important!

Can we add this to the FAQ please?

Thank you for your work and contribution to secure network connectivity!

Post Reply