Selected file has incorrect profile configuration

Post Reply
john_d13
OpenVpn Newbie
Posts: 2
Joined: Tue Dec 24, 2019 7:28 pm

Selected file has incorrect profile configuration

Post by john_d13 » Tue Dec 24, 2019 7:31 pm

I am able to successfully import the identical ovpn configuration via local file but if I try importing using URL I get this error - Failed to import profile "Selected file has incorrect profile configuration"

Using TLS and CA cert embedded in ovpn. Whats difference does it make with import method local vs url that can be generating this error ?

Do I need to be running Access server in order to use the URL import method ?

PhilippeS
OpenVpn Newbie
Posts: 1
Joined: Mon Mar 23, 2020 10:34 am

Re: Selected file has incorrect profile configuration

Post by PhilippeS » Mon Mar 23, 2020 10:38 am

I have the same question.

Have you found a solution ?

RandyS
OpenVpn Newbie
Posts: 9
Joined: Fri Nov 21, 2014 1:02 pm

Re: Selected file has incorrect profile configuration

Post by RandyS » Sun Apr 26, 2020 11:55 am

Same issue here. Any thoughts or solution?

sgrotz
OpenVpn Newbie
Posts: 1
Joined: Tue Apr 28, 2020 8:54 am

Re: Selected file has incorrect profile configuration

Post by sgrotz » Tue Apr 28, 2020 8:57 am

I dont have a solution, but I think I narrowed it down even further. If you look at your webservers access log files, when trying to import the certificate, you will see the following:

Code: Select all

[28/Apr/2020:10:51:50 +0200] "HEAD /vpn.ovpn?embedded=true HTTP/1.1" 200 395 "-" "-"
[28/Apr/2020:10:51:50 +0200] "POST /RPC2 HTTP/1.1" 404 628 "-" "-"
The first line downloads the ovpn file and once you try to import the file, it does the /RPC2 POST call, which is not available (at least on my server) - therefore it gets a 404 error back. Not sure what it is trying to do there, but I believe this is specifically for people using the openvpn-as server.

Any update from an expert would be appreciated.

p0o0uya
OpenVpn Newbie
Posts: 4
Joined: Mon Aug 03, 2020 9:52 am

Re: Selected file has incorrect profile configuration

Post by p0o0uya » Mon Aug 03, 2020 9:55 am

Hi,

I seem to be having the same issue. when I try to import the config file from the local drive everything goes fine. but when trying to import the same file using url import from my web server, after I enter credentials and click import I get the following error.

Failed to Import Profile
profile was not imported

Post Reply