openvpn - no upload when routing all traffic through VPN

Post Reply
born2lose
OpenVpn Newbie
Posts: 4
Joined: Sat Nov 14, 2015 10:56 pm

openvpn - no upload when routing all traffic through VPN

Post by born2lose » Sat Nov 14, 2015 11:10 pm

Hi,

I've had an issue for the last few days which is simply driving me nuts - hope someone here can shed some light.

Current setup: openvpn server running on a synology NAS behind a small SOHO router - and 3 clients, one android media player (minix neo x8h-plus), one macbook (using tunnelblick), one ipad.

exactly the same .ovpn profile exported to all 3 clients, everything works perfect when not routing traffic through the VPN. There are some services for which I need to use the server's external IP address, so I added 'push "redirect-gateway def1"' ' to the openvpn.conf file on the server. I had no dns, so I also added 'push "dhcp-option DNS 8.8.8.8"' to the server config. No change done to the clients' config files.

Everything still works as designed on the macbook and the ipad, however - the android device is not able to upload. general web browsing is fine, but random generic speedtests on the internet always come back with 0 upload on the android (same tests give similar results on the other 2 devices, and even download speed on the android is similar to the others). google play market also does not work when connected to the vpn, and a number of different services (streaming, for example).

I tried to disable the redirect from the server and add it to the local config file on the android - same issue. problem does not replicate on any of the other 2 devices.

same android media player works fine when connected to another openvpn server (again, with the redirect-gateway option enabled).

I have tried another openvpn client (random free client from the market) - same behaviour.

anyone, any idea what could be causing this? I would really appreciate some help...

xianin10483
OpenVpn Newbie
Posts: 1
Joined: Fri Nov 27, 2020 3:07 pm

Re: openvpn - no upload when routing all traffic through VPN

Post by xianin10483 » Fri Nov 27, 2020 3:16 pm

I ran into same/similar issue. General web browsing works fine when connected to OpenVPN. But ..., any attempt to upload data (send), doesn't work. I did few speedtest.net tests when on VPN. Download speed: no issue, Upload speed: 0Mb/s. What's even stranger, is that when I did speedtest on command line (i'm using linux client), it worked just fine. What the heck.

What's probably important to know here, is that on the VPN client I'm using mobile data connection (LTE) to connect to my home OpenVPN (cable). I initially configured OpenVPN using UDP transport. This is when I observed those strange issues with inability to send network traffic. I reconfigured my OpenVPN to use TCP transport instead. Result: all problems with network connectivity have been SOLVED !!!

I know it's an old post, but maybe some future readers will find it useful.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: openvpn - no upload when routing all traffic through VPN

Post by TinCanTech » Fri Nov 27, 2020 4:45 pm


300000
OpenVPN Super User
Posts: 426
Joined: Tue May 01, 2012 9:30 pm

Re: openvpn - no upload when routing all traffic through VPN

Post by 300000 » Fri Nov 27, 2020 9:08 pm

you need to add all of this into your server config to make it up load or download on good or bad connection . I try all of them and this is the best it can up and down , google play and everything work on my android phone and iPad. I have try download over many gb data or over openvpn on big files and on many small file , everything work as it should


hash-size 137552 155372
bcast-buffers 15379870
tun-mtu 60000
mssfix 0
fragment 0
sndbuf 3932106
rcvbuf 3932106
push "sndbuf 3932106"
push "rcvbuf 3932106"

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8374
Joined: Fri Jun 03, 2016 1:17 pm

Re: openvpn - no upload when routing all traffic through VPN

Post by TinCanTech » Fri Nov 27, 2020 9:37 pm

Knowing practically nothing about their network, you proclaim nonsense.

300000
OpenVPN Super User
Posts: 426
Joined: Tue May 01, 2012 9:30 pm

Re: openvpn - no upload when routing all traffic through VPN

Post by 300000 » Fri Nov 27, 2020 9:53 pm

they will try it if not works they will come back to complaint and at that time you will see. if nobody come back to say anything mean it work for them let waite and see.

Post Reply