VPN connects to server but seems unusable

Post Reply
IT.Grasshopper
OpenVpn Newbie
Posts: 3
Joined: Tue Sep 10, 2019 3:36 am

VPN connects to server but seems unusable

Post by IT.Grasshopper » Tue Sep 10, 2019 4:04 am

I have created a VPN server on a windows 10 machine. The server is active and I can connect to the server both locally and remotely using the android app. My ultimate objectives are first, to have the server PC and android device recognize one another so that I can connect to shared folders remotely; second, to use the VPN is a means to remotely sync files (through a service already functioning on my local network) between the two.

I have followed various guides and tutorials, and either I am doing something wrong, or I am missing something. Ultimately, I need help figuring this out. As of right now, my setup mimics the Easy Windows Guide.

When I am connected, if I ping the android VPN IP from the command line on the server, it works! However, if I ping the windows VPN IP from a terminal on the android phone, nothing happens; not even an error/failure message.

Any ideas on what to do next?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 6261
Joined: Fri Jun 03, 2016 1:17 pm

Re: VPN connects to server but seems unusable

Post by TinCanTech » Tue Sep 10, 2019 12:15 pm

Check your windows firewall ..

IT.Grasshopper
OpenVpn Newbie
Posts: 3
Joined: Tue Sep 10, 2019 3:36 am

Re: VPN connects to server but seems unusable

Post by IT.Grasshopper » Tue Sep 10, 2019 12:39 pm

FACEPALM! I feel pretty dumb right now. How did I miss that!

Anyway, the openVPN daemon is already set to allow incoming and outgoing traffic on the windows firewall. When I disabled the firewall completely, everything worked from both the windows and android and I was able to add my shared folder as well. Other than the openVPN daemon, what other firewall setting needs to change to allow the firewall to be enabled, but the VPN to continue to work?

IT.Grasshopper
OpenVpn Newbie
Posts: 3
Joined: Tue Sep 10, 2019 3:36 am

Re: VPN connects to server but seems unusable

Post by IT.Grasshopper » Wed Sep 11, 2019 1:30 am


Post Reply