static-challenge support

Post Reply
welder_pb
OpenVpn Newbie
Posts: 1
Joined: Tue Jul 31, 2018 3:00 pm

static-challenge support

Post by welder_pb » Tue Jul 31, 2018 3:05 pm

Hello.

I'v tried to use static-challenge protocol in latest version 3.0.5(1816)
Here is a fragment of config:
auth-user-pass
static-challenge "Enter One Time Password" 1

But client doesn't ask about OTP password. Only username and user password. How can i use static-challenge response?
Thank you.

Chizh
OpenVpn Newbie
Posts: 1
Joined: Wed Oct 10, 2018 2:45 pm

Re: static-challenge support

Post by Chizh » Wed Oct 10, 2018 2:47 pm

Hey, guy! Hope everything is ok and you are working fingers to the bone to make this work :)
We are experiencing the same issue in our organization and even created the support ticket, however since 27th of September there were no updates.

Can you please follow this up?

View Ticket: #GFE-647-91422

Appreciate if you could help us make MFA OTP to work on Android devices with your native application. :)

f4242
OpenVpn Newbie
Posts: 1
Joined: Tue Dec 04, 2018 6:29 pm

Re: static-challenge support

Post by f4242 » Tue Dec 04, 2018 6:33 pm

Hello,

I have the same problem with OpenVPN Connect 3.x on Android. A coworker also have the same problem on iOS. It was working great with OpenVPN Connect 1.x (and it still works when I use that version). Seem like version 3.x dropped that feature. Is it a voluntary drop or a bug?

On version 1, the login prompt asked my username, my password and the string configured in the openvpn profile at the "static-challenge" directive. On version 3, it only ask for username and password. I enter my password and it never ask the 2FA code, it just fails.

naingwintun
OpenVpn Newbie
Posts: 1
Joined: Mon Dec 10, 2018 2:55 am

Re: static-challenge support

Post by naingwintun » Mon Dec 10, 2018 3:15 am

thanks brother

Post Reply