"init-config" command is not recognized

Support forum for Easy-RSA certificate management suite.
Post Reply
JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

"init-config" command is not recognized

Post by JmLec » Tue Nov 03, 2020 1:47 pm

Bonjour
Je souhaite créer un tunnel sous Windows 10 pro x64 - Pour cela j'ai suivi le wiki Easy_Windows_Guide. Malheureusement, la commande "init-config" n'est pas reconnu! J'ai tenté diverses actions qui n'ont pas permis de résoudre le problème. Je suis donc bloqué. Merci pour vos réponses et votre aide.

Hello
I want to create a tunnel under Windows 10 pro x64 - For that I followed the Easy_Windows_Guide wiki. Unfortunately, the "init-config" command is not recognized! I tried various actions which failed to resolve the issue. So I am stuck. Thank you for your responses and your help.

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: HOWTO: Request Help !

Post by TinCanTech » Tue Nov 03, 2020 1:55 pm


JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: "init-config" command is not recognized

Post by JmLec » Tue Nov 03, 2020 3:50 pm

The command ./easyrsa help gives me access to the list of the following commands:
init-pki
build-ca [cmd-opts]
gen-dh
gen-req <filename_base> [cmd-opts]
sign-req <type> <filename_base>
build-client-full <filename_base> [cmd-opts]
build-server-full <filename_base> [cmd-opts]
revoke <filename_base> [cmd-opts]
renew <filename_base> [cmd-opts]
build-serverClient-full <filename_base> [cmd-opts]
gen-crl
update-db
show-req <filename_base> [cmd-opts]
show-cert <filename_base> [cmd-opts]
show-ca [cmd-opts]
import-req <request_file_path> <short_basename>
export-p7 <filename_base> [cmd-opts]
export-p8 <filename_base> [cmd-opts]
export-p12 <filename_base> [cmd-opts]
set-rsa-pass <filename_base> [cmd-opts]
set-ec-pass <filename_base> [cmd-opts]
upgrade <type>


I just installed OpenVPN-2.5.0-I601-amd64.msi with all its options. Which command to use?

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: "init-config" command is not recognized

Post by JmLec » Wed Nov 04, 2020 10:32 pm

What do I do now?

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Creating the configuration file pour WIndows

Post by JmLec » Fri Nov 06, 2020 2:28 pm

Hello,
I have no response to my first post. So I'm opening this new post in the hopes of generating more interest. Indeed, my first post may not have been clear enough.
I installed OpenVPN-2.5.0-I601-amd64.msi with all its options on Windows 10 pro.
I am new to OPENVPN Community Edition, so I followed the Easy_Windows_Guide. Unfortunately, I am unable to get the config file because from the start the "init-config" command is an unrecognized command.
What solutions to overcome this blockage can you provide me to finally create a VPN with OpenVPN.

Thanks in advance for all the helpful tips and tutorials you could give me
Last edited by Pippin on Fri Nov 06, 2020 2:33 pm, edited 1 time in total.
Reason: Merged, please do not post same question multiple times.

OpenMat
OpenVpn Newbie
Posts: 3
Joined: Tue Nov 17, 2020 1:18 am

Re: "init-config" command is not recognized

Post by OpenMat » Tue Nov 17, 2020 1:44 am

2.5.0 installer MSI is broken - download 2.4.9 and install using openvpn-install-2.4.9-I601-Win10.exe

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: "init-config" command is not recognized

Post by TinCanTech » Tue Nov 17, 2020 1:51 am

OpenMat wrote:
Tue Nov 17, 2020 1:44 am
2.5.0 installer MSI is broken
No it is not.
OpenMat wrote:
Tue Nov 17, 2020 1:44 am
2.5.0 installer MSI is broken - download 2.4.9 and install using openvpn-install-2.4.9-I601-Win10.exe
Do not do that.

OpenVPN 2.5 comes with Easy-RSA version 3.

fredtech
OpenVpn Newbie
Posts: 1
Joined: Fri Dec 04, 2020 2:25 pm

Re: "init-config" command is not recognized

Post by fredtech » Fri Dec 04, 2020 2:34 pm

I have the exact same problem as the OP. I'm also on Windows 10 Pro trying to install OpenVPN using the same version of the installer and nothing is working. Please can someone advise what I'm doing wrong?

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: "init-config" command is not recognized

Post by JmLec » Thu Dec 24, 2020 2:30 pm

Now i get that ! Anyone have any idea to fix this problem

EasyRSA Shell
# ./easyrsa init-pki

Easy-RSA error:

Temporary directory 'C:/Program Files/OpenVPN/easy-rsa/pki/easy-rsa-11776.a07248' does not exist

Easy-RSA error:

Failed to create temporary file

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: "init-config" command is not recognized

Post by TinCanTech » Thu Dec 24, 2020 2:53 pm

You must have admin privileges to use EasyRSA in that folder.

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: "init-config" command is not recognized

Post by JmLec » Thu Dec 24, 2020 3:17 pm

it is not possible to run in admin

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: "init-config" command is not recognized

Post by JmLec » Thu Dec 24, 2020 3:19 pm

when I run in admin the window opens and closes immediately

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: "init-config" command is not recognized

Post by TinCanTech » Thu Dec 24, 2020 3:42 pm

You must learn how to use Windows.

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: « init-config » commande n’est pas reconnu

Post by JmLec » Tue Dec 29, 2020 10:09 am

Strange way of doing and responding! I don't understand. While waiting when I need nothing, I ask TinCanTech

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: "init-config" command is not recognized

Post by TinCanTech » Tue Dec 29, 2020 5:46 pm

You must login to Windows with your Administrator account.

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: « init-config » commande n’est pas reconnu

Post by JmLec » Wed Dec 30, 2020 11:31 am

It has been from the start - the problem is still present

JmLec
OpenVpn Newbie
Posts: 11
Joined: Tue Nov 03, 2020 1:39 pm

Re: « init-config » commande n’est pas reconnu

Post by JmLec » Wed Dec 30, 2020 1:42 pm

it would have been easier to clarify that a standard administrator account is not enough. I just tried in super administrator session (hidden account). And miracle it works! I will continue to test but frankly the tutorials and informations are limited. To wonder if someone puts himself in the shoes of the users-
to believe that one likes to waste his time or then the preserve?

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8983
Joined: Fri Jun 03, 2016 1:17 pm

Re: "init-config" command is not recognized

Post by TinCanTech » Wed Dec 30, 2020 3:24 pm

Blame Microsoft...

Nagash
OpenVpn Newbie
Posts: 1
Joined: Thu Jan 14, 2021 3:52 am

Re: "init-config" command is not recognized

Post by Nagash » Thu Jan 14, 2021 3:57 am

This is what worked for me:
- run cmd as administrator
- in cmd change folder to your OpenVpn\easy-rsa with "cd" command (in my case: C:\Program Files\OpenVPN\easy-rsa)
- in cmd run EasyRSA-Start.bat
now when you run: "easyrsa init-pki" command will be executed without error and folder pki will be created

I hope it help somebody.

Post Reply