Unable to generate certificates

Support forum for Easy-RSA certificate management suite.
Post Reply
OpenVpn Newbie
Posts: 1
Joined: Mon Apr 18, 2016 9:28 pm

Unable to generate certificates

Post by sailingbikeruk » Mon Apr 18, 2016 9:33 pm

I am attempting to install OpenVPN on a Mac running OSX 10.11.4 (El Capitan) and was following the install listed here https://remonpel.nl/2012/02/set-up-an-o ... -your-mac/

I have all the dependencies installed

I have edited the vars file correctly as I best I can work out, but when I attempt to run clean-all.sh from the easy-rsa folder I get the following error:

./clean-all: line 13: test: Fusion: binary operator expected
you must define KEY_DIR

I enabled echo in the script to see what was happening and it seems that the spaces in the path to my KEY_DIR are not being escaped properly in the variable assignment.

The entry in the vars file is thus:
export KEY_DIR="$HOME/Documents/Certificates"

but the script is showing this when run with echo on

./clean-all: line 11: /Volumes/Mac: No such file or directory

the full path to the file is:

"/Volumes/Mac Fusion Drive/Users/iand/Documents/Certificates"

I have tried putting this in the vars file in its verbose form (as above) but it still fails to assign properly.

I have also tried to escape the spaces with suitably placed backspaces along the lines:

"/Volumes/Mac\ Fusion\ Drive/Users/iand/Documents/Certificates"

Can anyone advise on the correct syntax for the vars file please.



User avatar
OpenVPN Protagonist
Posts: 4081
Joined: Sat Aug 09, 2014 11:24 am

Re: Unable to generate certificates

Post by Traffic » Wed Apr 20, 2016 7:54 am

It looks like you are using an older version of easyrsa ..

Try easyrsa-v3-rc2:

Post Reply