First time server setup fails at 'build-key-server'

Support forum for Easy-RSA certificate management suite.
Post Reply
supermutant
OpenVpn Newbie
Posts: 4
Joined: Wed Jun 25, 2014 2:06 pm

First time server setup fails at 'build-key-server'

Post by supermutant » Wed Jun 25, 2014 2:17 pm

I have a dd-wrt router and aim to get openvpn on it to work so I can watch TV etcetera when I am not home. I use the guide as posted here on howtogeek.com.

To get to business, when I try to generate the server key I get the following error:

Code: Select all

Sign the certificate? [y/n]:y
failed to update database
TXT_DB error number 2
Kan C:\Program Files\OpenVPN\easy-rsa\keys\*.old niet vinden
I saw a similar post where one was unable to get the client to work but I couldn't resolve it by reading the comments there.

I made sure to always use a specific commonName and executed all in an administrator command prompt under Windows 7 x64.

What I noticed also is that I got the following message but it seemed it was of lesser importance?

Code: Select all

WARNING: can't open config file: /etc/ssl/openssl.cnf
Using configuration from openssl-1.0.0.cnf
I hope you can help!

supermutant
OpenVpn Newbie
Posts: 4
Joined: Wed Jun 25, 2014 2:06 pm

Re: First time server setup fails at 'build-key-server'

Post by supermutant » Wed Jun 25, 2014 3:39 pm

Already did but I will use the documentation you provided.
Thanks.

supermutant
OpenVpn Newbie
Posts: 4
Joined: Wed Jun 25, 2014 2:06 pm

Re: First time server setup fails at 'build-key-server'

Post by supermutant » Wed Jun 25, 2014 4:53 pm

I failed naming the common name as server, now I feel I setup all as I should have but I might have another issue;

The router running dd-wrt is setup behind the modem/router, but set on its dmz.
Unfortunately I can not find any instances when I try to connect as it times out on the (correct) external ip.

Is it not enough to set it to dmz or need I forward a specific port on the main modem/router also?
If possible I do not want to set the modem/router in bridge mode.

supermutant
OpenVpn Newbie
Posts: 4
Joined: Wed Jun 25, 2014 2:06 pm

Re: First time server setup fails at 'build-key-server'

Post by supermutant » Wed Jun 25, 2014 5:27 pm

I hoped that dmz would make sure all was directed to the second router.

Thank you for the replies, maybe it doesn't show but I did read a lot before asking here.
Will try again another day ;-)

Post Reply