email address checking wrong with hyphen in domain name

All comments and questions related to the functionality of the OpenVPN web pages and forum should go here.
Post Reply
higgins0
OpenVpn Newbie
Posts: 1
Joined: Fri Feb 21, 2020 11:30 am

email address checking wrong with hyphen in domain name

Post by higgins0 » Fri Feb 21, 2020 11:32 am

cannot use a domain name containing an "-" in the email address (falsely considered as a faulty character...). That should work...

User avatar
Pippin
Forum Team
Posts: 827
Joined: Wed Jul 01, 2015 8:03 am

Re: email address checking wrong with hyphen in domain name

Post by Pippin » Fri Feb 21, 2020 1:34 pm

For spam control I use a + sign in the local-part of the address.
On this forum that is not working also.

User avatar
ecrist
Forum Team
Posts: 260
Joined: Wed Nov 26, 2008 10:33 pm
Location: Minneapolis, MN
Contact:

Re: email address checking wrong with hyphen in domain name

Post by ecrist » Fri Feb 21, 2020 1:42 pm

Is your issue with PWM to register, or with the forum itself?
OpenVPN Community Administrator
IRC: #openvpn, #openvpn-devel Twitter: @ecrist
Co-Author of Mastering OpenVPN
Author of Troubleshooting OpenVPN

User avatar
Pippin
Forum Team
Posts: 827
Joined: Wed Jul 01, 2015 8:03 am

Re: email address checking wrong with hyphen in domain name

Post by Pippin » Fri Feb 21, 2020 1:44 pm

Uhm, I remember wrongly.
The forum works with user+ovpn@example.com
It's PWM that does not accept it, https://community.openvpn.net/pwm/private/login

Post Reply