Openvpn instance would become responsive once every while.

Post Reply
chetanmadaan
OpenVpn Newbie
Posts: 2
Joined: Mon Sep 28, 2020 1:51 pm

Openvpn instance would become responsive once every while.

Post by chetanmadaan » Mon Sep 28, 2020 2:05 pm

Hi,

I setup openvpn on a AWS instance and every other day or so it would become unresponsive, I'd restart the AWS instance it would be start working fine.

Looking further into it, I figured out it wasn't the AWS instance being unresponsive but the openvpn service inside.

This time when it become unresponsive, I pulled the status and below is is what I see:

Code: Select all

openvpnas@openvpnas2:~$ sudo systemctl status openvpnas
● openvpnas.service - OpenVPN Access Server Service
   Loaded: loaded (/etc/systemd/system/openvpnas.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Mon 2020-09-28 06:35:55 UTC; 6h ago
 Main PID: 1313 (code=killed, signal=KILL)
    Tasks: 0 (limit: 536)
   CGroup: /system.slice/openvpnas.service

Sep 24 15:41:15 openvpnas2 systemd[1]: Starting OpenVPN Access Server Service...
Sep 24 15:41:20 openvpnas2 systemd[1]: Started OpenVPN Access Server Service.
Sep 28 06:35:55 openvpnas2 systemd[1]: openvpnas.service: Main process exited, code=killed, status=9
Sep 28 06:35:55 openvpnas2 systemd[1]: openvpnas.service: Failed with result 'signal'.
lines 1-11/11 (END)...skipping...
● openvpnas.service - OpenVPN Access Server Service
   Loaded: loaded (/etc/systemd/system/openvpnas.service; enabled; vendor preset: enabled)
   Active: failed (Result: signal) since Mon 2020-09-28 06:35:55 UTC; 6h ago
 Main PID: 1313 (code=killed, signal=KILL)
    Tasks: 0 (limit: 536)
   CGroup: /system.slice/openvpnas.service

Sep 24 15:41:15 openvpnas2 systemd[1]: Starting OpenVPN Access Server Service...
Sep 24 15:41:20 openvpnas2 systemd[1]: Started OpenVPN Access Server Service.
Sep 28 06:35:55 openvpnas2 systemd[1]: openvpnas.service: Main process exited, code=killed, status=9/KILL
Sep 28 06:35:55 openvpnas2 systemd[1]: openvpnas.service: Failed with result 'signal'.
Is this expected behavior, am I missing something in the setup?

Thanks,
Chetan

chetanmadaan
OpenVpn Newbie
Posts: 2
Joined: Mon Sep 28, 2020 1:51 pm

Re: Openvpn instance would become responsive once every while.

Post by chetanmadaan » Thu Oct 29, 2020 2:20 pm

Nobody having thi issue?

Post Reply