client connects to server but cannot ping the server

Ask questions about your Access Server configuration here.
Post Reply
okos
OpenVpn Newbie
Posts: 3
Joined: Mon Nov 23, 2020 7:26 pm

client connects to server but cannot ping the server

Post by okos » Mon Nov 23, 2020 7:37 pm

Hi,

I am having trouble to connect to my openvpn server from a linux openvpn client (installed in debian 10). I cannot find a solution from all the available info out there. Hope someone con point me in the right direction.

I think I do connect to the openvpn because I get:

Code: Select all

ws1 nm-openvpn[6513]: [OpenVPN Server] Peer Connection Initiated with [AF_INET]2.189.89.61:1194" 
I also checked the client by trying to connect to PIA´s vpn using an ovpn file. It did work.

I can provide more info (pls ask me). This is what my client outputs BEFORE I connect to the VPN (openvpn-server):

Code: Select all

netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 enp4s0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 enp4s0

ifconfig -a
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.200  netmask 255.255.255.0  broadcast 192.168.1.255
       
lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
Now after I start the vpn client and try to connect:

Code: Select all

netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         172.27.224.1    0.0.0.0         UG        0 0          0 tun0
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 enp4s0
2.189.89.61     192.168.1.1     255.255.255.255 UGH       0 0          0 enp4s0
172.27.224.0    0.0.0.0         255.255.240.0   U         0 0          0 tun0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 enp4s0
192.168.1.1     0.0.0.0         255.255.255.255 UH        0 0          0 enp4s0

 ifconfig -a
enp4s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.200  netmask 255.255.255.0  broadcast 192.168.1.255

  lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0

tun0: flags=4305<UP,POINTOPOINT,RUNNING,NOARP,MULTICAST>  mtu 1500
        inet 172.27.224.14  netmask 255.255.240.0  destination 172.27.224.14
Rgds

User avatar
TinCanTech
OpenVPN Protagonist
Posts: 8354
Joined: Fri Jun 03, 2016 1:17 pm

Re: client connects to server but cannot ping the server

Post by TinCanTech » Mon Nov 23, 2020 10:35 pm

What version of Openvpn is that ?

okos
OpenVpn Newbie
Posts: 3
Joined: Mon Nov 23, 2020 7:26 pm

Re: client connects to server but cannot ping the server

Post by okos » Tue Nov 24, 2020 11:43 am

TinCanTech wrote:
Mon Nov 23, 2020 10:35 pm
What version of Openvpn is that ?
Access Server version: 2.8.6

okos
OpenVpn Newbie
Posts: 3
Joined: Mon Nov 23, 2020 7:26 pm

Re: client connects to server but cannot ping the server

Post by okos » Tue Nov 24, 2020 12:20 pm

I reviewed again my setup and I found the error. Sorry for wasting your time.

Post Reply