Routed config

Ask questions about your Access Server configuration here.
Post Reply
mcozzo
OpenVpn Newbie
Posts: 2
Joined: Sat Sep 28, 2019 10:44 pm

Routed config

Post by mcozzo » Sat Sep 28, 2019 10:53 pm

I'm having difficulty getting the appropriate L3 bits configured for my environment.

I have a Core L3 switch that handles all RFC1918 networks. From there my internet is handled by a firewall. I would like to span the internal and external networks with my OpenVPN server. The expectation is that client VPN traffic hits the core L3 before being routed to the firewall. The OVPN server has a leg in both internal and external networks. All L2 connectivity has been verified.

I'm running into an issue with the routing on the OVPN server.
0.0.0.0/0 should route to the ISP for client web authentication, VPN connection, etc.
All user traffic should route to the Core L3 device and then out through the firewall. Users at remote sites should hit the core and then out through the firewall.

Why:
I want to handle VPN traffic natively and not port forward through the firewall.
I want to be able to inspect client internet traffic using my firewall.
All of the rest of my traffic decisions happen on the core L3 device so I would like to retain that functionality.

Image

mcozzo
OpenVpn Newbie
Posts: 2
Joined: Sat Sep 28, 2019 10:44 pm

Re: Routed config

Post by mcozzo » Sat Sep 28, 2019 11:02 pm

I suppose for the client device the route table should read:
x.x.x.13 > ISP/DHCP

Regardless, I'll treat the endpoint as a full tunnel client and expect all of the traffic from it. That's not the question, the issue I have is that I can't actually load up the client authentication page, as there's no default route for that return traffic.

Post Reply