[HELP] - Can´t connect to my LAN with Raspberry

Need help configuring your VPN? Just post here and you'll get that help.
Forum rules
Please use the [oconf] BB tag for openvpn Configurations. See viewtopic.php?f=30&t=21589 for an example.
Post Reply
OpenVpn Newbie
Posts: 1
Joined: Wed May 10, 2017 5:21 pm

[HELP] - Can´t connect to my LAN with Raspberry

Post by ipillo » Wed May 10, 2017 5:32 pm

Hi Everyone:

This is my scenario.

I have 2 Raspberry Pi´s:

-One in my hometown running as an OpenVPN server (OS OSMC)

-The other one where I live running as a client (OS OSMC)

I´ve already created the credentials and certificates in order to access to the server, and tried them both in a Laptop Running Windows 10 with the OpenVPN GUI (where I can connect to the VPN withouth problems and access to the LAN, in this case to the server´s IP), and in my Raspberry Pi, where it connects to the VPN but it doesn´t access to the LAN (I´ve tried to ping the server´s IP with no response).

Can anyone give me a hand?

I´m quite newbie so if you need any kind of files (server conf, client conf...) please tell me so I can put it here.

Thanks in advance.

PS: If this is not the appropiate place for the post feel free to move it to the correct forum.

OpenVPN User
Posts: 15
Joined: Thu Mar 28, 2013 8:31 am

Re: [HELP] - Can´t connect to my LAN with Raspberry

Post by chilinux » Thu Jul 13, 2017 11:37 pm

I am not a forum administrator and can't move your post. However, I thought it might be helpful to point out that the reason no one has gotten back to you is probably related to this being posted in the wrong forum. The OpenVPN Access Server is a closed source control panel for OpenVPN and is packaged only for Intel based systems. Given you are specifying the OpenVPN server you are using is running on an ARM processor, what you are using is not the Access Server software package but rather the Community Edition. As such, you might want to consider posting in the Community Project: Server Administration forum. You may also be asked to product the OpenVPN client logs from the Windows 10 OpenVPN GUI.

One possible reasons for your problem may include not having turned on IPv4 or IPv6 forwarding such as running
sysctl -w net.ipv4.conf.all.forwarding=1
sysctl -w net.ipv6.conf.all.forwarding=1

Other reasons could be an iptables rule blocking the ping (either the ICMP echo-request or the return ICMP echo-reply) or a problem with the routing table.

If you can take the time to learn tcpdump, it can be a powerful tool to see what packets are making it across OpenVPN to the tun interface and also to see what packets are getting routed back out of the physical NIC.

Post Reply