Accessing local printers while connected to VPN?

Ask questions about your Access Server configuration here.
Post Reply
jockebq
OpenVpn Newbie
Posts: 7
Joined: Fri Oct 20, 2017 9:10 am

Accessing local printers while connected to VPN?

Post by jockebq » Fri Oct 20, 2017 9:18 am

Hi,

I'm using a Debian-based OS called OpenMediaVault. I updated to the newest version and also the newest version of OpenVPN AS. Before this, everything was working as expected. I could connect to my OpenVPN AS via Windows 10 from outside of my house and access my internal things, browsing the web using my own IP adress, but still being able to access and use the local printers.

After the update I can no longer access the printers, they are installed via SBS.domain.local, and they are shown as Offline.
If I do a search after the printers I am able to find them, which means they are there, but there are some kind of conflict with the .local adress.
I tried changing from .lan (on my NAS) to .local, without any change.
The IP-adresses of the printers are not the same as anything in my network.

I don't know what, and if any settings has changes from the newer versions.

Any ideas? Help is much appreciated!
OpenMediaVault is based on Debian 8 Jessie, and I use OpenVPN AS 2.1.12.

jockebq
OpenVpn Newbie
Posts: 7
Joined: Fri Oct 20, 2017 9:10 am

Re: Accessing local printers while connected to VPN?

Post by jockebq » Mon Nov 06, 2017 1:58 pm

I cannot figure this out. The printers are installed to Windows this way:
\\SBS.company.local\Konica Minolta C452
If I right click this printer I can see that it has this IP-adress: 192.168.0.27
When connected to VPN I am able to add the printer via the IP-adress, but it is not possible to access it via the adress above, which is what I need.

I have tried to add the adress SBS.company.local to "DNS resolution zones (optional)", I also tried with company.local and local. Nothing works.
On the network which has the VPN server the adress is called .lan, so there should be no problem there, also my IP-adress is using 192.168.1.1, and not 192.168.0.1 as the computer with the printers.
I have also tried adding 192.168.0.1/32 to "Specify the private subnets", nothing helps.

So what should I do?

Post Reply