Page 1 of 1

Ubuntu 20 depenancy issue

Posted: Thu Mar 25, 2021 2:12 pm
by lawshosting
This was posted a while ago but had no replies (here).

I have a similar thing, but with other dependency issues:
Unpacking openvpn-as (2.8.7-c7d6c210-Ubuntu20) ...
dpkg: dependency problems prevent configuration of openvpn-as:
openvpn-as depends on libffi7 (>= 3.3~20180313); however:
Package libffi7 is not installed.
openvpn-as depends on python-netaddr; however:
Package python-netaddr is not installed.
openvpn-as depends on openvpn-as-bundled-clients; however:
Package openvpn-as-bundled-clients is not installed.

phython3-nettaddr is installed, there's no phython-nettaddr, nor a libffi7, there is a libffi8ubuntu1....

Can someone point me on how to install this on Ubuntu groovy

Re: Ubuntu 20 depenancy issue

Posted: Thu Mar 25, 2021 5:47 pm
by openvpn_inc

You are seeing this problem on Ubuntu Groovy Gorilla because we have not built or released Access Server for Ubuntu Groovy Gorilla. It is not an LTS version and therefore we do not support it.

See also this page listing the system requirements, and particularly the note about only supporting Ubuntu LTS releases: ... uirements/

To be honest I don't expect you'll be able to get this working like this. If you want to run this on Ubuntu 20, then you may use Ubuntu 20.04 Focal Fossa LTS release.

Kind regards,