web interface says connection refused..

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
murdocklawless
OpenVpn Newbie
Posts: 5
Joined: Sun Nov 06, 2016 7:31 pm

web interface says connection refused..

Post by murdocklawless » Wed Feb 17, 2021 3:20 pm

hi all,

I get an ubuntu 20.04 vps and install openvpn-as on it. setup was ok, no errors but I can not connect web interface. I opened port 943 over iptables. nettstat showed that no one is listening port 943. also openvpnas service is working.

I was able to use openvpn-as with ubuntu 16.04.

what is the problem?

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 35
Joined: Tue Feb 16, 2021 10:41 am

Re: web interface says connection refused..

Post by openvpn_inc » Thu Feb 18, 2021 12:31 pm

Hi murdocklawless,

It's hard to tell with such limited information. But OpenVPN Access Server on Ubuntu 20.04 should work just fine - it is supported. You do mention it's a VPS. In almost all cases that's fine, but in rare cases a custom kernel is compiled by some VPS providers that doesn't let certain iptables modules load. You could check output of uname -a to see what your kernel looks like. This is a sample of what it looks like with a generic Ubuntu kernel on an Ubuntu 20.04 installation;
Linux ubuntu20x64 5.4.0-48-generic #52Ubuntu SMP Thu Sep 10 10:58:49 UTC 2020 x86_64 x86_64 GNUX/Linux

If you see something like 5.4.0-48-kimsufi-custom-compiled in there it might be a custom kernel that could mess things up. In the past we used to encounter this a lot more but it's pretty rare these days that we see VPS providers doing that kind of custom kernel compiling.

Please make sure that when you installed Access Server that it was the latest version - older versions were not supported on Ubuntu 20 yet. The first one that supported it was 2.8.6 but you may as well get the latest version. You can find the install instructions here;
https://openvpn.net/vpn-software-packages/

If you copied your configuration from a previous Access Server installation onto this one - so not a fresh installation - then it's possible the configuration contains instructions to bind to a particular network interface that existed on the previous server installation but not on this server. If so use the reset commands from here to fix that;
https://openvpn.net/vpn-server-resource ... o_defaults

If you still have problems, you should do:
service openvpnas stop
service openvpnas start

And then look at the last 100 or so lines in /var/log/openvpnas.log to see if there is anything there that contains the word 'error' and if so post that particular error message here so we can advise you further.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.nets/support

Post Reply