Openvpn AS web gui exits after start

Post Reply
legija
OpenVpn Newbie
Posts: 2
Joined: Thu Oct 29, 2020 6:44 pm

Openvpn AS web gui exits after start

Post by legija » Thu Oct 29, 2020 6:54 pm

So, I did read lots of instructions and it was pointed out that this is caused by kernel in most cases.

I have CentOS 7.x installed on two separate server machines, both running CWP, one free and other pro version.
On both machines installed identical CentOS minimal versions, along with CSF.

On server with CWP Pro, OpenvpnAS installed and working, but web gui fails to work as it just starts briefly and exits.
On server with CWP free version, everything worked from first try.

Code: Select all

2020-10-23T02:21:35+0200 [stdout#info] [WEB] OUT: '2020-10-23T02:21:35+0200 [stdout#info] Web server running as UID 1032'
2020-10-23T02:21:36+0200 [stdout#info] [WEB] OUT: '2020-10-23T02:21:36+0200 [stderr#error] Server agent has died, web server shutting down'
Kernel version:
3.10.0-1127.13.1.el7.x86_64
Loaded iptables modules:

Code: Select all

lsmod | grep iptable
iptable_filter         12810  1
iptable_raw            12678  0
iptable_mangle         12695  1
iptable_nat            12875  1
nf_nat_ipv4            14115  1 iptable_nat
ip_tables              27126  4 iptable_filter,iptable_mangle,iptable_nat,iptable_raw
I tried many times to reinit settings, even removing access server and reinstalling from start again, each time it installs and then fails on start.
VPN server itself works fine, I was able to generate profile from CLI.

Is there something I missed here, or something I could modify to at least see some debug info on why web gui process exits ?

legija
OpenVpn Newbie
Posts: 2
Joined: Thu Oct 29, 2020 6:44 pm

Re: Openvpn AS web gui exits after start

Post by legija » Wed Dec 09, 2020 10:45 pm

Just installed today's update and problem remains.

How is it that nobody has any idea on how to solve this problem ?

Super0n6
OpenVpn Newbie
Posts: 5
Joined: Thu Dec 17, 2020 9:49 am

Re: Openvpn AS web gui exits after start

Post by Super0n6 » Sun Dec 20, 2020 7:08 am

Just curious is there any paricular reason why you are running CentOS 7.x?

terminateurb12
OpenVpn Newbie
Posts: 1
Joined: Tue Dec 29, 2020 7:25 am

Re: Openvpn AS web gui exits after start

Post by terminateurb12 » Tue Dec 29, 2020 7:26 am

Hello, any update on this I'm having the same problem as legija on centos 7.

Post Reply