Basic VPN connections

Business solution to host your own OpenVPN server with web management interface and bundled clients.
Post Reply
flammeur
OpenVpn Newbie
Posts: 1
Joined: Sun Sep 13, 2020 9:51 am

Basic VPN connections

Post by flammeur » Sun Sep 13, 2020 9:59 am

Hello folks

I am completly stuck to connect my openvpn outside of my network:

I set up the openvpn with centos , i created a user and set the password on centos and on administration page openvpn

i redirect port on 943 and 1194 on tcp and udp from my box

When on local network i import profile it work i can connect to my machine, however outside my network i connect to the openvpn administration page import the profile but this time doesn't work

From the log looks like it doesn't go throught my public IP wich :

Code: Select all

 9/13/2020, 11:51:24 AM Connecting to [192.168.1.27]:1194 (192.168.1.27) via UDPv4
⏎9/13/2020, 11:51:28 AM Server poll timeout, trying next remote entry...
⏎9/13/2020, 11:51:28 AM EVENT: RECONNECTING ⏎9/13/2020, 11:51:28 AM EVENT: RESOLVE ⏎9/13/2020, 11:51:28 AM Contacting 192.168.1.27:1194 via UDP
⏎9/13/2020, 11:51:28 AM WinCommandAgent: transmitting bypass route to 192.168.1.27
{
	"host" : "192.168.1.27",
	"ipv6" : false
}

⏎9/13/2020, 11:51:28 AM EVENT: WAIT ⏎9/13/2020, 11:51:28 AM Connecting to [192.168.1.27]:1194 (192.168.1.27) via UDPv4
⏎9/13/2020, 11:51:32 AM EVENT: CONNECTION_TIMEOUT ⏎9/13/2020, 11:51:32 AM EVENT: DISCONNECTED ⏎
Last edited by Pippin on Sun Sep 13, 2020 10:04 am, edited 1 time in total.
Reason: Formatting

racole20m
OpenVpn Newbie
Posts: 1
Joined: Wed Feb 17, 2021 10:57 am

Re: Basic VPN connections

Post by racole20m » Wed Feb 17, 2021 10:59 am

This is the same problem I encounter. I still don't have the solutions for this one. Were you able to solve it? Mine also routes to private IP instead of the public IP

User avatar
openvpn_inc
OpenVPN Inc.
Posts: 35
Joined: Tue Feb 16, 2021 10:41 am

Re: Basic VPN connections

Post by openvpn_inc » Wed Feb 17, 2021 12:12 pm

Hello,

This is very simple to explain and resolve. When you setup your OpenVPN Access Server, you most likely did so on a system that had no public IP, but only a private IP. It then takes that IP as the basis for client VPN connection configurations. In your case that would be 192.168.1.27. That would work perfectly fine while you are in your private network, but would not work on the Internet obviously.

The best solution is to make sure you have some DNS record that points to your public IP, and configure Access Server to use that for client VPN connection configurations. After you configure this, you need to load a new copy of the connection profile into your VPN client. This is one of the few settings that does not get updated automatically on the VPN client side.

Technically you can also just do public IP, but the downside of that is that your public IP might change, and if it does, you would need to configure it again on your Access Server, and then VPN clients would need to get a new connection profile to get connected to the new public IP again. So I recommend using a DNS record that resolves to your public IP, and then configuring that in the Access Server, and then importing that profile into the VPN client.

The setting for this is in the web based admin UI under Network Settings. Put it in the 'Host name or IP address' field. Save settings and update running servers. Then import a new VPN connection profile into your VPN client and it should then try to connect to the DNS record that resolves to your public IP, go through your router, and reach your Access Server, and establish a connection.

Kind regards,
Johan
Image OpenVPN Inc.
Answers provided by OpenVPN Inc. staff members here are provided on a voluntary best-effort basis, and no rights can be claimed on the basis of answers posted in this public forum. If you wish to get official support from OpenVPN Inc. please use the official support ticket system: https://openvpn.nets/support

Post Reply