Can't login to OpenVPN AS admin portal

Post Reply
drewjohnson
OpenVpn Newbie
Posts: 2
Joined: Fri May 01, 2020 3:29 pm

Can't login to OpenVPN AS admin portal

Post by drewjohnson » Fri May 01, 2020 4:10 pm

Running OpenVPN AS on Debian. Server was working fine until last night when I shutdown to do a backup. After backup, brought the server back up, and now getting this message when attempting to login to the admin console (https://serverIP:943/admin)

Sorry, a session error has occurred
It is possible that your session has expired or your login credentials do not allow access to this resource. See error text below for further details:

SESSION ERROR: SESSION: Your session has expired, please reauthenticate (9007)

I've searched for this specific message in the forums, and checked DNS settings. I do have servers in /etc/resolv.conf. I can also ping and curl outbound with no issues, so it looks like DNS and Internet connectivity are working.

Any help will be greatly appreciated. Thanks - Drew

drewjohnson
OpenVpn Newbie
Posts: 2
Joined: Fri May 01, 2020 3:29 pm

Re: Can't login to OpenVPN AS admin portal

Post by drewjohnson » Sat May 02, 2020 3:31 am

I banged on the server (Debian 9, OpenVPN-AS 2.8.3) for a bit tonite. After trying several things, I got it working. Here is what I did:
as root:
apt-get --purge remove openvpn-as
apt-get install openvpn-as
passwd openvpn

I have no idea what caused the issue. I was using the free 2 connection license, and still am. I can only hypothesize that running the clone backup changed something in the drive configuration that made OpenVPN-AS believe it was no longer on the same system. Interesting note; I didn't have to configure anything - all my settings, user profiles, and DB remained fully intact.

Post Reply