Cannot upgrade to as-2.8.0

Post Reply
theflakes
OpenVpn Newbie
Posts: 2
Joined: Tue Feb 11, 2020 1:06 pm

Cannot upgrade to as-2.8.0

Post by theflakes » Tue Feb 11, 2020 1:09 pm

I'm running AS on Centos 8. Seeing the below error when trying to upgrade.

Error:
Problem: cannot install the best update candidate for package openvpn-as-2.7.5_932a08a3-CentOSrelease.x86_64
- nothing provides MySQL-python needed by openvpn-as-2.8.0_beb4c556-CentOS7.x86_64
- nothing provides python >= 2.7 needed by openvpn-as-2.8.0_beb4c556-CentOS7.x86_64

Python 2.6 is installed and there is a symbolic link to /usr/bin/python.

theflakes
OpenVpn Newbie
Posts: 2
Joined: Tue Feb 11, 2020 1:06 pm

Re: Cannot upgrade to as-2.8.0

Post by theflakes » Tue Feb 11, 2020 1:19 pm

The server is using the CentOS7 repo. Can I switch to the CentOS8 repo and then upgrade, or will that break OpenVPN AS?

Post Reply