Page 1 of 1

Windows 10 no name resolution after install and reboot.

Posted: Fri Oct 04, 2019 10:24 pm
by Lynkd34d
Greetings,

I work in support, and I have a customer who i'm in the process of getting her set up on Windows 10. She still has her old Windows 8.1 laptop right now as well.

The issue is on the Windows 10 laptop. All connectivity is fine and peachy until she installs OpenVPN Connect, and then reboots.
She works from home. Her system gets it's IP from her home router and ipconfig /all has a proper configuration for her home network, but for a reason I have yet to be able to figure out, after the reboot after the install she no longer has internet connectivity. She can ping certain well known IP's, like 8.8.8.8 but names will not resolve. I have even tried setting her dns entries manually to static entries like 8.8.8.8.

Her other system, the Windows 8.1 system works without any issue, both connect to the same OpenVPN server, the Windows 10 system does still connect to the OpenVPN server after the reboot. But disconnected or connected on OpenVPN, the computer becomes unable to resolve/connect to anything else.

Whatever OpenVPN does to the Windows 10 system is not removed by uninstalling, or switching to another user account on the system, or even switching between wired and wireless. Only by resetting windows back and wiping everything out were we able to get connectivity back.

The install causing the issue is OpenVPN, but I don't know or where or what needs to be changed to let regular internet connectivity work on this Window 10 system. I'm a bit at the end of my rope here reaching out for help.

We have no access to modify the server or check server logs or run any commands on it. As I said she has connectivity on her older 8.1 laptop just fine. No trouble there.

it's a bit of a tough situation as she is remote and I guide her on things to check and change to try and get this working again. As I said though i've only been able to restore connectivity by Completely resetting Windows.

Thanks for your time,
- Mike

Re: Windows 10 no name resolution after install and reboot.

Posted: Sat Oct 05, 2019 1:31 pm
by novaflash
Try adding the IP address and the host name of her VPN server to the Windows 10 hosts file, then connecting, and then disconnecting.

Re: Windows 10 no name resolution after install and reboot.

Posted: Thu Nov 07, 2019 5:52 pm
by tuckeryates
We've been experiencing something similar. we are a small business with 70 total employees, roughly 35 of which use openvpn regularly. Seemingly randomly after installing the openvpn client, some users are not able to access the internet via ethernet or wireless adapter. Once it happens, only a system recovery works (re-installing the OS). Initiating a system restore to a day before the issue showed up does not help. We originally thought it was an issue with a specific laptop model, but now we noticed that only the 35 openvpn users experience this issue. No users without vpn accounts have experienced this. Has anyone else had issues with this, and if so, are there better troubleshooting steps other than a factory reset?

EDIT: Our openvpnas version is 2.7.4 and we are running OSI Layer 3 (routing/NAT)

Re: Windows 10 no name resolution after install and reboot.

Posted: Sat Nov 09, 2019 10:52 am
by novaflash
Can you add what version and name of software you are using? In regards to the VPN client software, and the OS as well.