UNable to make openVPN window client working

Post Reply
Fathzer
OpenVpn Newbie
Posts: 1
Joined: Thu Sep 19, 2019 9:11 am

UNable to make openVPN window client working

Post by Fathzer » Thu Sep 19, 2019 1:45 pm

Hello,
I'm new to OpenVPN and installed an openVPN server on a docker machine hosted outside my LAN using the linuxserver/openvpn-as image (version 2.7.5-ls39 that runs an openVPN access server 2.7.5).
I used the docker-compose file found at https://hub.docker.com/r/linuxserver/openvpn-as/, and simply changed the hostname in the network settings configuration to match the DNS Name of my server.
I installed clients on Android and Linux and it works without any problem :-)
I installed recommended Windows client (version 3.0.0.272) configured with the client.opvn delivered by the server, but it does not work.
Connection is established (both client and server claim it is), but the Windows (10 version 19.03) machine is unable to connect to any remote address.
I tried older client (2.7.1.101) and tried on other PCs (one has a fresh install of Windows on it) without any success.
As ping and nslookup commands failed to find IP addresses, I had a look at the "TAP-Windows Adapter" IP v4 properties. It looks strange: The "Utiliser l'adresse IP suivante" (I presume it's "Use the following IP address" in US systems) is selected ... but no IP is defined. The DNS is set to 127.0.0.11. If I set IP and DNS to be automatically obtained, nslookup still fail.
If I set the DNS address to the Google ones (8.8.8.8), nslookup works, but ping still fails.
What am I doing wrong?

Post Reply