Local IP showing up in log (OpenVPN Connect)

Post Reply
joaquin.gonzalez
OpenVpn Newbie
Posts: 1
Joined: Tue Sep 17, 2019 2:13 pm

Local IP showing up in log (OpenVPN Connect)

Post by joaquin.gonzalez » Tue Sep 17, 2019 2:22 pm

Hello and thank you for your help.
I'm trying to set up a new VPN for connecting to the office LAN from the workers private networks.
So I set up the server in a Ubuntu computer, correctly can access it trough https://192.168.0.12:943/admin and https://192.168.0.12:943/
I have set up the router with a public IP 88.27.xx.xx and set up forward rules for ports 943 and 1194 (UTP and TCP)

So from a windows PC outside my network I can go to https://88.27.xx.xx:943/ and correctly log in with a user, download the client (Open VPN connect) and try to set up a new connection. I put in server address 88.27.xx.xx and in port I have tried both 1194 and 943 but cant get connection.

The first strange thing is that I'm asked if I want to trust the certificate, with all the correct info showing, so I suppose some kind of connection must be made.

Then the connection times out with no answer, I check de logs and that's the weird stuff.

In the log file from the client the connection is being tried to made with the IP 192.168.0.12 (the local IP of the server) instead of 88.27.xx.xx (the one put in the client configuration), don't know if this is a normal behavior or this is where the problem is. If this is the problem I have no idea of what is causing or how can be fix.

Any help?

Post Reply