Client not connecting after changing protocol

Post Reply
jimmyk
OpenVpn Newbie
Posts: 2
Joined: Sun Sep 01, 2019 12:05 pm

Client not connecting after changing protocol

Post by jimmyk » Sun Sep 01, 2019 12:17 pm

I have a SSL website using 443 and access server running at the same time. The website is working and the vpn user login and admin login is working both on port https://<IP>:943, but now the clients cannot connect. Under protocol, I turned off Both (Multi-daemon mode) and only using TCP because thats the only way I can get everything to work together.

So how do I get the clients to connect now? Do I change "Web Service forwarding settings" - "Admin Web Server" settings, or "Client Web Server" settings.

Thanks for any help.

novaflash
I should be on the dev team.
Posts: 978
Joined: Fri Apr 13, 2012 8:43 pm

Re: Client not connecting after changing protocol

Post by novaflash » Wed Sep 04, 2019 5:23 pm

The problem is that Access Server is using port TCP 443 by default too, for communication between the client software and the server software for negotiating credentials and connection profiles. By running another web service on port 443 this breaks that functionality. At least if I understand the situation right, this is the problem.

The solution is to configure the Access Server to use TCP and UDP (multi-daemon) as that is simply sensible to do, and then to change the port TCP 443 to something else like TCP 444 or something, and making that port available so it reaches the Access Server. And then reinstall your OpenVPN clients so they use the new instructions to reach the Access Server on the newly configured port(s).

jimmyk
OpenVpn Newbie
Posts: 2
Joined: Sun Sep 01, 2019 12:05 pm

Re: Client not connecting after changing protocol

Post by jimmyk » Wed Sep 04, 2019 10:05 pm

Thanks...that worked!. Now everything is working. Awsome.

novaflash
I should be on the dev team.
Posts: 978
Joined: Fri Apr 13, 2012 8:43 pm

Re: Client not connecting after changing protocol

Post by novaflash » Thu Sep 05, 2019 12:49 pm

Great. Have a nice day.

Post Reply