Connection Error on Mac & iOS, Works on Windows

Post Reply
seabuzz
OpenVpn Newbie
Posts: 2
Joined: Wed Aug 28, 2019 5:07 pm

Connection Error on Mac & iOS, Works on Windows

Post by seabuzz » Wed Aug 28, 2019 5:12 pm

Trying to connect to my OpenVPN server with a .ovpn file. Connection works perfectly on Windows 10.

Copying the .ovpn file to Mac or iOS, I get the following error:

{'timestamp': 1567010788, 'type': 'FATAL', 'error': 'CERT_VERIFY_FAIL: mbed TLS: SSL read error : X509 - Certificate verification failed, e.g. CRL, CA or signature check failed'}

:x

Using:
Signature Algorithm: sha256WithRSAEncryption
Subject Public Key Info:
Public Key Algorithm: rsaEncryption
Public-Key: (2048 bit)

Anyone else have this issue??

novaflash
I should be on the dev team.
Posts: 978
Joined: Fri Apr 13, 2012 8:43 pm

Re: Connection Error on Mac & iOS, Works on Windows

Post by novaflash » Wed Aug 28, 2019 5:58 pm

Probably the method that you used to copy the ovpn file has corrupted it somehow. I know linebreaks can be pretty annoying between certain operating systems. Are you copying the file as a file or are you copy/pasting the information somehow?

Please note you can just go to the OpenVPN Access Server web interface, log on as a user, and download the connection profile for that user (use the user-locked or auto-login type profile). You can do that straight from the macOS or iOS device.

seabuzz
OpenVpn Newbie
Posts: 2
Joined: Wed Aug 28, 2019 5:07 pm

Re: Connection Error on Mac & iOS, Works on Windows

Post by seabuzz » Fri Aug 30, 2019 4:46 pm

Thanks - I was able to fix the issue by removing the following line from the client config file. I think this value has been depreciated.

ns-cert-type server

novaflash
I should be on the dev team.
Posts: 978
Joined: Fri Apr 13, 2012 8:43 pm

Re: Connection Error on Mac & iOS, Works on Windows

Post by novaflash » Fri Aug 30, 2019 5:23 pm

I have no idea how that could be the issue. That's been there forever on Access Server, and we test our clients on Access Server. Everything I know says this can not be the problem/solution.

novaflash
I should be on the dev team.
Posts: 978
Joined: Fri Apr 13, 2012 8:43 pm

Re: Connection Error on Mac & iOS, Works on Windows

Post by novaflash » Fri Aug 30, 2019 9:04 pm

Looks like this might be a bug in Access Server after all. We'll investigate and resolve. In the meantime the solution is making sure that the bootstrap user actually exists.

Post Reply