OpenVPN AS + Mikrotik Bad compression stub decompression header byte

Post Reply
Dmitry
OpenVpn Newbie
Posts: 3
Joined: Thu Aug 08, 2019 5:26 pm

OpenVPN AS + Mikrotik Bad compression stub decompression header byte

Post by Dmitry » Tue Aug 13, 2019 1:56 pm

Hello

I installed OpenVPN Access Server (ver. 2.7.4) and i cannot connect to it from mikrotik router (RouterOS ver. 6.45.3) as OpenVPN clinet.
More precisely, the connection passes, but the traffic through the tunnel does not go
In server logs i've got an errors like that (username and IP address changed):

Code: Select all

2019-08-13T14:35:01+0300 [stdout#info] [OVPN 0] OUT: 'Tue Aug 13 11:35:01 2019 client/192.168.0.105:57668 Bad compression stub decompression header byte: 69'
From linux and windows clients connects without any problems and traffic goes.
In OpenVPN AS Configuration:
Network Settings => Protocol = TCP
Advanced VPN => Default Compression Settings = OFF
Advanced VPN => Default TLS Auth Settings = OFF

PS
Prior to this set up Mikrotiks as clients and everything worked well, but there was the usual (OpenSource) OpenVPN server (NOT Access Server).
I have been looking for information about this error on the Internet and on this forum, but I have not found any working solution.

Dmitry
OpenVpn Newbie
Posts: 3
Joined: Thu Aug 08, 2019 5:26 pm

Re: OpenVPN AS + Mikrotik Bad compression stub decompression header byte

Post by Dmitry » Tue Aug 20, 2019 3:18 am

Logs from OpenVPN Access Server^

Code: Select all

Bad compression stub decompression header byte: 42'

Code: Select all

Bad compression stub decompression header byte: 69'
Correct me if I'm wrong.As far as I understand, such errors are due to not agreeing the traffic compression settings, but on the server compression is disabled at all, mikrotik as the client does not support compression at all.
When checking on windows\linux clients the configuration with the switched-off compression also comes, but at the same time VPN normally works.
Even I tried to change the MTU setting on a mikrotik, but it wouldn't work.
Please point me to the right direction.

Dmitry
OpenVpn Newbie
Posts: 3
Joined: Thu Aug 08, 2019 5:26 pm

Re: OpenVPN AS + Mikrotik Bad compression stub decompression header byte

Post by Dmitry » Fri Aug 23, 2019 11:01 am

At all mikrotik(routeros) without problems works with openvpn access server?

Post Reply