Network Functionality Not Restored After Power Outage

Post Reply
OpenVpn Newbie
Posts: 2
Joined: Wed Oct 12, 2016 11:35 pm

Network Functionality Not Restored After Power Outage

Post by thomas-amain » Fri May 10, 2019 7:01 pm

I am using OpenVPN AS 2.6.1 on a perimeter CentOS 7 box at home. My wife and I use OpenVPN client on Windows 10 Pro boxes to access our home network. Yesterday I kicked my power strip and powered off my workstation at work while connected to my home network via the client. When my workstation came back online, I was able to ping and resolve addresses via command line, but the shell was unaware that it was connected to the Internet. There was a yellow ! on my network connection and none of the shell apps (browsers, etc.) were able to access the Internet. I rebooted twice then it occurred to me what may be happening so I reconnected to my home network via the client and shell apps could again communicate. Functionality was retained after I correctly disconnected from my home network as well.

Would this be considered a bug? It would seem that while connected, the client is making a change that the shell apps see but command line utilities do not. Is this a known issue?

OpenVpn Newbie
Posts: 1
Joined: Mon Jul 13, 2020 8:17 pm

Re: Network Functionality Not Restored After Power Outage

Post by danielc2 » Mon Jul 13, 2020 8:29 pm

+1. The same issue happened to me last night. Was connected from my home Windows 10 client to our work network vial the OpenVPN client ( - Access Server V2.7.3. Lost power at home while connected. After that Windows was convinced that I did not have network access. I rebooted several times, tried disabling network drivers, changing IPV4 settings, cleared DNS cache, ETC. I even had a VM running via VirtualBox on the same machine that DID have internet access. NSLOOKUP from the command line to worked just fine, but ping failed.

The only thing that fixed this issue was reconnecting via the OpenVPN VPN client and then gracefully exiting. Then everything was back to normal.

I spent all day working on this. I finally stumbled across a post online where someone with the same issue performed some WireShark traces and found that a lot of network traffic was still going to the network that he was previously VPN'd to with OpenVPN:

I would definitely consider this a bug.

OpenVPN Inc.
Posts: 1055
Joined: Fri Apr 13, 2012 8:43 pm

Re: Network Functionality Not Restored After Power Outage

Post by novaflash » Thu Jul 16, 2020 7:41 pm

Please always make sure you're using the latest available software clients. Often these types of bugs are already resolved in up-to-date releases, and it's just older client software still floating around where such an issue can occur.

Post Reply