Stuck configuring OpenVPN AS on Azure

Post Reply
jitodr
OpenVpn Newbie
Posts: 1
Joined: Fri Apr 19, 2019 4:48 pm

Stuck configuring OpenVPN AS on Azure

Post by jitodr » Fri Apr 19, 2019 5:05 pm

I am trying to deploy OVPN-AS onto Azure via the Azure Marketplace offering that is maintained by OpenVPN. The current image version available is 2.6.1.

In the first attempt, I created the administrator account with an SSH public key. After logging into the instance via SSH, I am stuck when the script creates the Web UI admin account "openvpn" with the "same password used to authenticate to this UNIX host", as the Web UI does not support certificate-based login and I could not change the account password via SSH as my account does not have root access (I don't have the root password to perform su or passwd either).

No issue, I deleted the whole resource group and start over. This time I chose password authentication when creating the VM. Again, the config script auto-executed upon me agreeing to the EULA, and I created the same "openvpn" account for admin UI. However, I could not log into the web UI at all at https://public_ip_of_azure_vm:943 with "openvpn" as the user and the password I used to log on to the SSH. Eventually, I was locked out from the admin web UI due to too many wrong password attempts. I've checked the network security group and it already has all the required access rules (inbound TCP 943, 443, 22 and UDP 1194 allowed with all outbound allowed).

Any help logging into the 943 Web UI admin portal is appreciated. The FAQ and guides are no longer accurate as the passwd method and default root account password no longer works with the Azure Marketplace image.

Thank you in advance!

novaflash
I should be on the dev team.
Posts: 1017
Joined: Fri Apr 13, 2012 8:43 pm

Re: Stuck configuring OpenVPN AS on Azure

Post by novaflash » Fri Apr 19, 2019 6:32 pm

The account 'openvpnas' has sudo rights, meaning you can become root. Just type for example sudo su once logged on through SSH.

Post Reply